Central Directory corrupt.

Klaus M. Jensen's Avatar

Klaus M. Jensen

26 Jan, 2024 01:38 PM

Hey,

I have just setup a new Environment on an existing solution, but the deploy fails with the error "Central Directory corrupt." (shows in AppVeyor under environments, and Event Viewer on the server).

Doing deployments with Deployment Agent(v 6.3.3.3241) on Windows Server 2022 Standard 21H2

Any idea why this happens ?

  1. 1 Posted by Klaus M. Jensen on 26 Jan, 2024 03:15 PM

    Klaus M. Jensen's Avatar

    A side note.
    The server is a newly setup server.

  2. Support Staff 2 Posted by Feodor Fitsner on 26 Jan, 2024 06:50 PM

    Feodor Fitsner's Avatar

    Hi Klaus,

    It's because Deployment Agent cannot download the artifact from storage server. Downloaded file is 0 size. You can try download it from AppVeyor UI on that server or with AppVeyor API.

    Based on our experience, it's because of some firewall settings or other networking appliances preventing access to the storage server.

  3. 3 Posted by Klaus M, Jensen on 29 Jan, 2024 12:26 PM

    Klaus M, Jensen's Avatar

    Hej Feodor,
    Thank you very much - as you said, i can not download the artifact from AppVeyor UI, so raisied the issue with network guys :)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac