Build error: can not find any service with service name 'msmq'

odinserj's Avatar

odinserj

30 May, 2014 07:10 AM

Hello, I'm using MSMQ service to do integration testing for my project. To use it, I've included it in my appveyor.yml:

enable service required for tests

services:
- mssql2008r2sp2 - msmq

Everything was awesome until yesterday I tried to run a build, and in the beginning it logged the following message:

9 Start-Service : Cannot find any service with service name 'msmq'. 10 At line:1 char:1
11 + Start-Service 'msmq'
12 + ~~~~~~~~~~~~~~~~~~~~
13 + CategoryInfo : ObjectNotFound: (msmq:String) [Start-Service], ServiceCommandException
14 + FullyQualifiedErrorId : NoServiceFoundForGivenName,Microsoft.PowerShell.Commands.StartServiceCommand

Build URL: https://ci.appveyor.com/project/odinserj/hangfire/build/0.8.3.484

  1. Support Staff 1 Posted by Feodor Fitsner on 30 May, 2014 01:30 PM

    Feodor Fitsner's Avatar

    Will fix that shortly! Thanks for letting us know.

    - Feodor

  2. Support Staff 2 Posted by Feodor Fitsner on 30 May, 2014 06:35 PM

    Feodor Fitsner's Avatar

    MSMQ service has been deployed to the latest image. Sorry for that, it's a new Windows Server 2012 R2 build worker image has been introduced as a default choice recently.

  3. 3 Posted by odinserj on 30 May, 2014 06:47 PM

    odinserj's Avatar

    It works now! Thank you for the best cloud CI!

    30 мая 2014 г., в 22:35, Feodor Fitsner <[email blocked]> написал(а):

  4. odinserj closed this discussion on 31 May, 2014 03:20 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac