Packaging artifacts...OK (but no artifacts were created)

cguardia's Avatar

cguardia

17 Nov, 2015 04:09 PM

Hi,
I'm trying to configure a JOB with MsBuild that creates a publish folder, and package that folder as an artifact, but it isn't created.
I've tryied also to add a dir, but i'm getting confused about paths.
Thanks in advance,
Christian

My appveyor.yml is:
version: 1.0.{build}
shallow_clone: true
environment:
  matrix:
  - solution_name: Source\YiQi.MVC
  - solution_name: Source\YiQi.Admin
before_build:
  - nuget restore %solution_name%.sln
build:
  publish_wap_xcopy: true
  verbosity: minimal
after_build:
- cmd: >-
    dir Source\%solution_name%\%solution_name%\publish_%solution_name%

    dir yiqi\Source\%solution_name%\%solution_name%\publish_%solution_name%
build_script:
  - msbuild %solution_name%.sln /p:DeployOnBuild=true /p:PublishProfile=DeployToTemp /p:Configuration=Release /t:Rebuild
configuration:
  - Release
artifacts:
- path: Source\%solution_name%\%solution_name%\publish_%solution_name%
  name: '%solution_name%'
  type: zip

  1. Support Staff 1 Posted by Feodor Fitsner on 17 Nov, 2015 06:10 PM

    Feodor Fitsner's Avatar

    Artifacts path Source\%solution_name%\%solution_name%\publish_%solution_name% doesn't look right.

    If you substitute %solution_name% with one of those values you'll get something like:

    Source\Source\YiQi.MVC\Source\YiQi.MVC\publish_Source\YiQi.MVC
    
  2. 2 Posted by cguardia on 17 Nov, 2015 06:13 PM

    cguardia's Avatar

    Hi Feodor!
    Thanks for your answer. I've solved using fixed path instead of a variable
    one.
    Thanks again

  3. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:02 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac