Appveyor doesn't see my tag

Stefanos Anastasiou's Avatar

Stefanos Anastasiou

19 Nov, 2015 12:04 AM

Hi,

I have a small problem here. I am trying to push tags in another branch upon successful commit / with a specific message. All works well except the fact, that during deployment I am getting this warning:

Skip "GitHub" deployment as environment variable has not matched ("appveyor_repo_tag" is "false", should be "true")

This is a sample payload:

{
  "ref": "refs/tags/v0.7.228",
  "before": "0000000000000000000000000000000000000000",
  "after": "1fc65c7d16d07068a2487434f66432c28c0886c4",
  "created": true,
  "deleted": false,
  "forced": true,
  "base_ref": "refs/heads/master",
  "compare": "https://github.com/sanastasiou/RTextNpp/compare/v0.7.228",
  "commits": [

The tag appears correctly in github.

Now if I manually add a tag, then it works.. but this is exactly what I want to avoid.

Project is here:

https://ci.appveyor.com/project/sanastasiou/rtextnpp

Thanks for any help!

  1. Support Staff 1 Posted by Feodor Fitsner on 19 Nov, 2015 12:36 AM

    Feodor Fitsner's Avatar

    Looks like this is the build you are looking for: https://ci.appveyor.com/project/sanastasiou/rtextnpp/build/0.7.229, right?

  2. 2 Posted by Stefanos Anasta... on 19 Nov, 2015 07:30 AM

    Stefanos Anastasiou's Avatar

    Hey, it worked ;)

    Sorry, was too l8 :)

    Perfect! Thanks a bunch.

  3. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:02 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac