Auto-detection Failed

jacob.bjorke's Avatar

jacob.bjorke

24 Nov, 2015 05:35 PM

I recently added a .gitignore file to my repo. After adding it everything built fine, so I created a PR where all the files in the now ignored directories are deleted. Now the build no longer passes.

I have since added a pre-build command to retore nuget packages. And in the settings->build given a direct path to my .sln.

Below is the error I am getting (names etc have been removed).

Build started
git clone -q --branch=remove-files git@github.com:<repo name>.git C:\projects\<project name>
git checkout -qf <hash>
nuget restore
MSBuild auto-detection: using msbuild version '14.0' from 'C:\Program Files (x86)\MSBuild\14.0\bin'.
This folder contains no solution files, nor packages.config files.
Command exited with code 1

Any help would be greatly appreciated.

Thanks,
Jake

  1. 1 Posted by jacob.bjorke on 24 Nov, 2015 05:39 PM

    jacob.bjorke's Avatar

    When I clone the repo from GitHub and do a package restore on the solution then build solution it works without a problem. I am assuming its a problem in my configuration.

  2. Support Staff 2 Posted by Feodor Fitsner on 24 Nov, 2015 06:25 PM

    Feodor Fitsner's Avatar

    Use nuget restore <path-to\solution.sln> command instead.

  3. 3 Posted by jacob.bjorke on 24 Nov, 2015 07:46 PM

    jacob.bjorke's Avatar

    That did the trick. Thanks Feodor.

  4. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:02 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac