Error pushing artifact: The operation has timed out

jerome.vuarand's Avatar

jerome.vuarand

25 Nov, 2015 01:07 AM

I'm trying to run automated release builds for a rather large collection of libraries. It worked fine last time I tried a few months ago, but today it failed. It turned out one of the dependencies downloaded from the web had changed URL. After fixing it though, the build doesn't complete because my after_build packaging script fails to upload artifacts with the following message:

Error pushing artifact: The operation has timed out

The project job and sources are all open, so feel free to have a look and request tests: doub/prtr-lua/build/job/owla4fx90iphybyt

The problem seems similar to these two issues:

The solution proposed there (using PS command from appeveyor.yml) doesn't apply to me directly because I generate artifact names from a custom script, which then call appveyor.exe to upload the artifacts. I don't know whether I can call PowerShell from my script, and whether that would solve the issue (since it would be a different process from the one running the appveyor.yml).

Any suggestion?

  1. Support Staff 1 Posted by Feodor Fitsner on 25 Nov, 2015 01:19 AM

    Feodor Fitsner's Avatar

    Try generating artifacts in project build folder C:\projects\prtr-lua, say in C:\projects\prtr-lua\out and then collecting them with:

    artifacts:
    - path: 'out\*.zip'
    
  2. 2 Posted by jerome.vuarand on 25 Nov, 2015 02:31 AM

    jerome.vuarand's Avatar

    The workaround seems to be working. Test fail at the moment because of the
    reduced build, I've started a full and I'll try to check results tomorrow.

    I've noticed that you forked the build project. Note that it's not a
    reproducible build as it get the tip of other unrelated repositories that
    will evolve independently. But it should be OK in the short term.

    Please tell me when the bug in appveyor.exe is fixed, or alternatively if
    you find another easy way for me to push artifacts from my script. I guess
    I could try the REST API is nothing better comes up.

  3. 3 Posted by jerome.vuarand on 25 Nov, 2015 06:13 PM

    jerome.vuarand's Avatar

    The proposed wordaround pushes the artifacts, but it is not a solution for me at the moment. The "out\" subdirectory becomes part of the artifact name, and my FTP deploy rule will put the file in a "out" subdirectory on the target server, which is an issue.

    I also tried the REST API. While creating and updating tests works, I still can't push artifacts. The PUT api/artifacts request on APPVEYOR_API_URL times out.

  4. Support Staff 4 Posted by Feodor Fitsner on 25 Nov, 2015 06:16 PM

    Feodor Fitsner's Avatar

    Put artifacts to the root of build folder or move appveyor PushArtifact command out of package.lua.

  5. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:02 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac