error MSB4019

Tim Geyssens's Avatar

Tim Geyssens

01 Dec, 2015 01:59 PM

Hey,

My projects are currently failing to build with the error

Build FAILED.
 
"C:\projects\umbracopagenotfoundmanager\BuildPackages\Package.build.xml" (default target) (1) ->
"C:\projects\umbracopagenotfoundmanager\PageNotFoundManager\PageNotFoundManager.csproj" (default target) (2) ->
  C:\projects\umbracopagenotfoundmanager\PageNotFoundManager\PageNotFoundManager.csproj(311,3): error MSB4019: The imported project "C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v10.0\WebApplications\Microsoft.WebApplication.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.
 
    0 Warning(s)
    1 Error(s)

This used to work in the past ... any changes that recently happened to appveyor that I need to take into account?

Thanks,
Tim

  1. Support Staff 1 Posted by Feodor Fitsner on 01 Dec, 2015 07:27 PM

    Feodor Fitsner's Avatar

    Hi Tim,

    Looks like the project still relies on Visual Studio 2010. We re-installed OSS build worker images from scratch on a new environment and right now they have only Visual C++ 2010 installed to support building of some native node.js and Python projects.

    For web projects there are both VS 2013 and VS 2015 are available.

  2. 2 Posted by Tim Geyssens on 01 Dec, 2015 08:37 PM

    Tim Geyssens's Avatar

    Ok thanks for the help, will see if I can update :) (it's already a vs 2013 solution)

  3. 3 Posted by Tim Geyssens on 01 Dec, 2015 08:58 PM

    Tim Geyssens's Avatar

    Ok in my csproj file I changed the import from

    to

    and

    10.0
    to

    12.0

    But still no luck

  4. Support Staff 4 Posted by Feodor Fitsner on 01 Dec, 2015 09:24 PM

    Feodor Fitsner's Avatar

    What error do you get now?

  5. 5 Posted by Tim Geyssens on 02 Dec, 2015 07:21 AM

    Tim Geyssens's Avatar

    Was still the same error, but missed an import that was still referring to v10 so once I updated that it was all good, thanks for the support!

  6. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:02 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac