Bitbucket repos - webhooks not triggering

julian.elve's Avatar

julian.elve

15 Dec, 2015 12:20 PM

Have seen earlier posts re authorization errors - not seeing that, and I can trigger a manual build. Triggered builds are not starting though - which is a major pain as I need to build my production branch....

Anything we can do from our end?

thanks

Julian

  1. Support Staff 1 Posted by Feodor Fitsner on 15 Dec, 2015 02:50 PM

    Feodor Fitsner's Avatar

    Make sure you use service POST hooks, not "webhooks" which are not supported yet.

  2. 2 Posted by julian.elve on 15 Dec, 2015 02:52 PM

    julian.elve's Avatar

    Yes – this is an existing project that has been building successfully for over a year ☺

  3. Support Staff 3 Posted by Feodor Fitsner on 15 Dec, 2015 02:59 PM

    Feodor Fitsner's Avatar

    I've just checked a test BitBucket repo and new build was automatically triggered when I updated a file via their web UI. Webhooks IP filters were updated earlier to support new IPs.
    Have you changed something in project configuration (like allowed branches for instance)?

    -Feodor

  4. 4 Posted by julian.elve on 15 Dec, 2015 03:01 PM

    julian.elve's Avatar

    I haven’t, sorry.

    I’m about 20 mins away from a new commit onto Production, so will update this ticket after that

  5. 5 Posted by julian.elve on 15 Dec, 2015 03:39 PM

    julian.elve's Avatar

    Con firmed it fires OK now, thanks

  6. julian.elve closed this discussion on 15 Dec, 2015 03:39 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac