Build Failing for unknown reason

jezz.santos's Avatar

jezz.santos

03 Jan, 2016 06:04 AM

Suddenly (i.e. I am not sure what changed that could affect this) but I am getting failed builds.
(error is attrached)

I've not experienced this kind of error before with MSBUILD.
On a clean desktop build using same command line we don't see this.

Have you seen this before?
I am stumped as to where to start.

  1. Support Staff 1 Posted by Feodor Fitsner on 03 Jan, 2016 06:15 AM

    Feodor Fitsner's Avatar

    Nothing has been changed on build workers yet. Try re-building previous successful commit to see if some changes in the code/project cause this.

  2. 2 Posted by jezz.santos on 03 Jan, 2016 06:23 AM

    jezz.santos's Avatar

    One thing that did change, and that is new on this build definition was that I moved from CMD to PS for the MSBUILD.EXE part.
    Perhap it is related?

  3. Support Staff 3 Posted by Feodor Fitsner on 03 Jan, 2016 07:46 PM

    Feodor Fitsner's Avatar

    Well, I'm not sure PowerShell could be a reason.

  4. 4 Posted by jezz.santos on 04 Jan, 2016 09:17 AM

    jezz.santos's Avatar

    Well, I never really understood the fix, but I discovered that Bcl.Build.targets was causing the build issue for one of my projects.

    The only way I could fix it, was either remove the Bcl.Builds.targets files from the project or add this MSBUILD property to skip the offending tasks <SkipEnsureBindingRedirects>true</SkipEnsureBindingRedirects>

    God knows why this has become an issue now, and why only for that one project!!!!

  5. jezz.santos closed this discussion on 04 Jan, 2016 09:17 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac