No tests discovered

brian dunnington's Avatar

brian dunnington

06 Jun, 2014 03:38 PM

So after the latest fixes, my Universal Windows/Windows Phone 8.1 solution & projects are building successfully now. However, once the build is complete and the app packages are created, the build output shows 'Discovering Tests...' and then 'Done'. No tests are discovered even though I have several test projects with tests in them (though they are discovered and ran in Visual Studio). Here is my latest build output if that helps:

https://ci.appveyor.com/project/briandunnington/testappforbuildserver

  1. Support Staff 1 Posted by Feodor Fitsner on 06 Jun, 2014 04:33 PM

    Feodor Fitsner's Avatar

    Hi Brian,

    I'm looking into build log... are Tests.Windows\bin\x86\Debug\Tests.Windows.dll and Tests.WindowsPhone\bin\x86\Debug\Tests.WindowsPhone.dll the two assemblies that must be automatically discovered?

  2. 2 Posted by Brian Dunningto... on 06 Jun, 2014 05:57 PM

    Brian Dunnington's Avatar

    Yes, those are the test projects. Thanks!
    ________________________________

  3. Support Staff 3 Posted by Feodor Fitsner on 09 Jun, 2014 07:53 PM

    Feodor Fitsner's Avatar

    Hi Brian,

    Sorry for the silly question, but what must be installed to make these guys resolve in proj file?

    <ItemGroup>
        <!--A reference to the entire .Net Framework and Windows SDK are automatically included-->
        <SDKReference Include="MSTestFramework, Version=12.0" />
        <SDKReference Include="TestPlatform, Version=12.0" />
      </ItemGroup>
    
  4. Support Staff 4 Posted by Feodor Fitsner on 09 Jun, 2014 08:02 PM

    Feodor Fitsner's Avatar
  5. Support Staff 5 Posted by Feodor Fitsner on 09 Jun, 2014 11:47 PM

    Feodor Fitsner's Avatar

    Well, it appears it's not just discovering Store/Phone assemblies with unit tests. The tests must be run as .appx packages.

    This is the guide: http://blogs.msdn.com/b/vikramagrawal/archive/2012/05/06/running-un...

    Have you tried following that guide to see if it's possible at AppVeyor? Based on your results we might add automation for Store/Phone tests.

  6. 6 Posted by Brian Dunningto... on 10 Jun, 2014 12:01 AM

    Brian Dunnington's Avatar

    I have verified those steps and am able to run my store (appx) tests via the command line (in Jenkins, using vstest.console.exe). I did have to get a developer license onto my build machine as well as install the app signing certificate in order to get it to work. I was just hoping AppVeyor could make it all easier since the rest of your service is so easy to setup and use, and Windows Store and Phone apps are becoming a bigger and bigger part of our development process.
    ________________________________

  7. Support Staff 7 Posted by Feodor Fitsner on 10 Jun, 2014 07:40 PM

    Feodor Fitsner's Avatar

    Yeah, the service is new and not all cases are covered. But we'd like to start working on appx testing support on AppVeyor, hopefully with your help.

  8. 8 Posted by brian dunningto... on 13 Jun, 2014 08:09 PM

    brian dunnington's Avatar

    I would be happy to help out. Testing appx packages brings a bunch of hurdles (must run in interactive mode, need developer license, need to install app signing cert, etc) so it would be great if AppVeyor could handle all of that seamlessly.

  9. Support Staff 9 Posted by Feodor Fitsner on 13 Jun, 2014 08:17 PM

    Feodor Fitsner's Avatar

    Yeah, I've started investigating that. Looks like developer license could not be deployed from command line... There is a cmdlet but it brings up a dialog window asking to enter Live ID.

    Maybe there is a place in the registry or local ceritificate store where we can just push dev certificate?..

  10. 10 Posted by Ville Rantala on 20 Mar, 2015 11:21 AM

    Ville Rantala's Avatar

    I wasn't sure if this issue was already solved so created it to https://github.com/appveyor/ci/issues/201 for easier tracking. If there is already a solution available, please share and I'll close the referenced issue.

  11. 11 Posted by briandunnington on 24 Aug, 2015 08:05 PM

    briandunnington's Avatar

    What was the final resolution on this? I read through the entire GitHub issue tracker thread but didnt see if it ever fully worked. I just tried rebuilding my original project that started this thread (almost a year ago) and got the same behavior: projects build successfully but no tests are discovered.

  12. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:59 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac