Network interface issues since switch to GCE

mscdex's Avatar

mscdex

11 Jan, 2016 02:25 AM

I have an OSS project (free) that has been running tests with the Windows 2012 image for a long while now and only recently have they started to fail. My tests install and use WinPCap (4.1.3).

The problem is that when I iterate over the interfaces via WinPCap, I no longer get the private LAN address(es) for the interface. I do get the device name and description just fine however.

Example log from before when it was working: https://ci.appveyor.com/project/mscdex/cap/build/18/job/mgf2wdgs319yxc96
Example log that I ran recently: https://ci.appveyor.com/project/mscdex/cap/build/job/o7tepefwl2ruswgu

I ran the same tests on my own fresh, vanilla win2012r2 image and had no problems there.

At first when I saw the interface description I was thoroughly confused ('Red Hat' on a Windows system!) until I learned it must have to do with how GCE sets things up?

Is there some kind of permission issue at play here or something else?

  1. Support Staff 1 Posted by Feodor Fitsner on 11 Jan, 2016 02:38 AM

    Feodor Fitsner's Avatar

    Yes, right now OSS projects run on Google Compute Engine instances. No permissions or anything else set to block any functionality of VM - it's stock GCE VM behind NAT.

  2. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:03 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

16 Jul, 2019 05:17 PM
16 Jul, 2019 10:17 AM
16 Jul, 2019 07:46 AM
16 Jul, 2019 04:51 AM
15 Jul, 2019 06:33 PM

 

15 Jul, 2019 06:09 PM
15 Jul, 2019 05:53 PM
15 Jul, 2019 05:46 PM
15 Jul, 2019 05:21 PM
15 Jul, 2019 04:29 PM
15 Jul, 2019 03:12 PM