MSBUILD Version 14

bniemyjski's Avatar

bniemyjski

11 Apr, 2016 09:40 PM

I made a single change to a source code file (C#) and now my build started using MSBuild 14 although it's been targeting MSBUILD 12 before. I require MSBUILD 12 and now my build fails:

https://ci.appveyor.com/project/Exceptionless/exceptionless-net/build/3.4.1643

  1. Support Staff 1 Posted by Feodor Fitsner on 11 Apr, 2016 10:02 PM

    Feodor Fitsner's Avatar

    Will take a look. We've rolled out VS 2015 Update 2: http://www.appveyor.com/updates/2016/04/11 - use "previous" image for now.

    -Feodor

  2. 2 Posted by bniemyjski on 11 Apr, 2016 10:10 PM

    bniemyjski's Avatar

    so do I just do os:previous? becuse I wasn't specifying an os before...

    Thanks
    -Blake Niemyjski

  3. Support Staff 3 Posted by Feodor Fitsner on 11 Apr, 2016 10:13 PM

    Feodor Fitsner's Avatar

    There are instructions at the bottom of that update post.

    -Feodor

  4. 4 Posted by bniemyjski on 11 Apr, 2016 10:16 PM

    bniemyjski's Avatar

    I've updated it to the previous build image, if you could let me know what
    caused this issue and when I can upgrade to the latest image that would be
    greatly appreciated

    Thanks
    -Blake Niemyjski

  5. 5 Posted by bniemyjski on 11 Apr, 2016 10:59 PM

    bniemyjski's Avatar

    I moved to the previous build image and the same thing. I literally change
    nothing that would of changed this setting. What do I need to change to get
    to the previous image? I was never setting the os and setting it to
    previous vs2015 causes issues

    Thanks
    -Blake Niemyjski

  6. Support Staff 6 Posted by Feodor Fitsner on 11 Apr, 2016 11:04 PM

    Feodor Fitsner's Avatar
  7. 7 Posted by bniemyjski on 11 Apr, 2016 11:06 PM

    bniemyjski's Avatar

    No there are lots of warnings.. it was working on 42 I don't think the build is failing properly

    Sent from Outlook Mobile

  8. Support Staff 8 Posted by Feodor Fitsner on 11 Apr, 2016 11:32 PM

    Feodor Fitsner's Avatar
  9. 9 Posted by bniemyjski on 11 Apr, 2016 11:33 PM

    bniemyjski's Avatar

    Yes! 

    Sent from Outlook Mobile

  10. 10 Posted by bniemyjski on 11 Apr, 2016 11:33 PM

    bniemyjski's Avatar

    We were using default build which was msbuild 12

    Sent from Outlook Mobile

  11. Support Staff 11 Posted by Feodor Fitsner on 11 Apr, 2016 11:40 PM

    Feodor Fitsner's Avatar

    OK, let me check something...

  12. Support Staff 12 Posted by Feodor Fitsner on 11 Apr, 2016 11:58 PM

    Feodor Fitsner's Avatar

    Found a bug. Will deploy an update with the fix later today.

  13. 13 Posted by bniemyjski on 12 Apr, 2016 02:15 AM

    bniemyjski's Avatar

    Thanks for the heads up!

    On Mon, Apr 11, 2016 at 6:58 PM, Feodor Fitsner <
    [email blocked]> wrote:

    > Found a

    Thanks
    -Blake Niemyjski

  14. Support Staff 14 Posted by Feodor Fitsner on 12 Apr, 2016 03:41 AM

    Feodor Fitsner's Avatar

    Update with the fix has been deployed!

  15. 15 Posted by bniemyjski on 12 Apr, 2016 03:55 AM

    bniemyjski's Avatar

    Thank you! What was the root issue (curious)

    Sent from Outlook Mobile

  16. Support Staff 16 Posted by Feodor Fitsner on 12 Apr, 2016 03:57 AM

    Feodor Fitsner's Avatar

    We've been working on a new algorithm for distributing workload across Hyper-V hosts. That was regression, in fact - wrong image passed to a build worker.

  17. 17 Posted by bniemyjski on 12 Apr, 2016 04:00 AM

    bniemyjski's Avatar

    I hope you guys can get a good nights sleep now!

    Sent from Outlook Mobile

  18. Support Staff 18 Posted by Feodor Fitsner on 12 Apr, 2016 04:02 AM

    Feodor Fitsner's Avatar

    Thanks! :)

  19. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:05 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac