Webdeploy to azure app service broken?

julian.elve's Avatar

julian.elve

04 Oct, 2016 10:01 PM

A project which deployed perfectly to Azure last time I built it (a couple of months) now fails at web deploy stage with

Could not complete the request to remote agent URL 'https://site.scm.azurewebsites.net/msdeploy.axd?site=site';.

A new project created today fails with same problem

Any clues please?

  1. 1 Posted by Ilya Finkelshte... on 04 Oct, 2016 10:18 PM

    Ilya Finkelshteyn's Avatar

    Hi Julian,

    Please check that NTLM is disabled in deployment provider settings. Also please check that you can deploy new project created today with Visual Studio.

    --ilya.

  2. Support Staff 2 Posted by Feodor Fitsner on 04 Oct, 2016 11:50 PM

    Feodor Fitsner's Avatar

    Just did publishing to both staging and production Azure web sites and it worked like a charm: https://ci.appveyor.com/project/AppVeyor-Website/website/build/1.0....

  3. 3 Posted by julian.elve on 05 Oct, 2016 05:11 AM

    julian.elve's Avatar

    NTLM is set to false in both projects but will test direct publish today

  4. 4 Posted by julian.elve on 05 Oct, 2016 07:05 AM

    julian.elve's Avatar

    Hmm, importing a freshly-downloaded .PublishSettings into VS2013 and trying a direct deployment still fails with the same error (a timeout).

    So seems it's not Appveyor but something else.

    If I resolve it I'll post the answer here

  5. 5 Posted by julian.elve on 05 Oct, 2016 07:24 AM

    julian.elve's Avatar

    Ok sorted - Azure server resource problem. The two projects I had problems with were both (with another service) on the same appservice plan, which was on the lowest scale setting and was running 98% CPU. Upscaling has resolved the issue.

  6. julian.elve closed this discussion on 05 Oct, 2016 07:24 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac