Can not use SQL Server 2016

Ken Collins's Avatar

Ken Collins

05 Oct, 2016 11:43 AM

I tried start this both via the services entry as well as via powershelgl like the other instances I test on. Nothing works. Here is the output from using services entry in the appveyor.yml:

Starting SQL Server 2016 Developer
Start-Service : Cannot find any service with service name 'MSSQL$SQL2016'.
At line:1 char:1
+ Start-Service 'MSSQL$SQL2016'
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (MSSQL$SQL2016:String) [Start-Service], ServiceCommandException
    + Ful
  1. 1 Posted by Ilya Finkelshte... on 05 Oct, 2016 06:49 PM

    Ilya Finkelshteyn's Avatar

    Hi Ken,

    Sorry for the trouble. We realized that for some historical reason your account is internally bound to Visual Studio 2013 image. We change it to default Visual Studio 2015. If you still need Visual Studio 2013 image, please set image: Visual Studio 2013 in your appveyor.yml. But SQL Server 2016 is not going to be installed on this Visual Studio 2013 image.

    --ilya.

  2. 2 Posted by Ken Collins on 05 Oct, 2016 09:45 PM

    Ken Collins's Avatar

    Thanks so much! Seems to work great now.

  3. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:08 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac