Node.js 6.9.0 seems broken

Daniel15's Avatar


19 Oct, 2016 06:10 AM

Our build seems to have broken once Node.js 6.9.0 was released.

> 'node' is not recognized as an internal or external command, operable program or batch file

Working build:
Failing build:

  1. Support Staff 1 Posted by Feodor Fitsner on 19 Oct, 2016 06:49 AM

    Feodor Fitsner's Avatar

    Look at the line 20:

    yarn Chocolatey package installs node 6.8.1 as dependency. Most probably node installer breaks/updates pre-defined PATHs to node versions.

    I'd install Yarn directly without Chocolatey and node dependencies like:

    - ps: Install-Product node $env:node_version
    - ps: (New-Object Net.WebClient).DownloadFile('', "$env:TEMP\yarn.msi")
    - ps: cmd /c start /wait msiexec /i "$env:TEMP\yarn.msi" /quiet
    - set PATH=C:\Program Files (x86)\Yarn\bin;%PATH%
    - yarn install
  2. 2 Posted by Daniel15 on 19 Oct, 2016 06:51 AM

    Daniel15's Avatar

    But how/why did it work before? What caused it to break? Also, our "node.js 4" build is still passing, even though it's also pulling Node 6 through Chocolatey: (I guess this isn't actually using Node v4)

    I might remove the Node 4 build (just have a Node 6 build) and remove the "Install-Product" call, and let it download Node via Chocolatey. Do you think that'd work?

  3. Support Staff 3 Posted by Feodor Fitsner on 19 Oct, 2016 07:14 PM

    Feodor Fitsner's Avatar

    You should look into how Chocolatey installs Node.js as dependency.

    However, you should better install Yarn without dependencies at all by using -i (ignore dependencies) switch:

      - ps: Install-Product node $env:node_version
      - choco install -i yarn
      - refreshenv
      - yarn install
  4. 4 Posted by Daniel15 on 19 Oct, 2016 10:36 PM

    Daniel15's Avatar

    Thank you! Adding the -i flag worked.

  5. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:09 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac