Artifact not deploying

byron's Avatar

byron

25 Jul, 2014 04:17 PM

My project, https://ci.appveyor.com/project/bsommardahl/pgci, is building fine but fails to deploy the artifact. I've tried different forms of the artifact path, but it always says the same thing:

...
Packaging artifacts...Done
Uploading artifact build\IvoryTower.Web-1.0.14.zip (2.7 MB)...Done
Deploying using WebDeploy provider
No artifacts were uploaded. Make sure you have specified correct artifacts filter.
Build success

Here's the artifact and deployment section of my appveyor.yml:

artifacts:
  - path: deploy\*.zip

deploy:
  - provider: WebDeploy
    server: https://waws-prod-blu-017.publish.azurewebsites.windows.net:443/msdeploy.axd?site=something
    website: something
    username: $something
    password: KJHKLJHKLHKLHJK77657jJHGKJHG
    ntlm: false
    artifact: deploy\*.zip

What do you think I'm doing wrong?

  1. Support Staff 1 Posted by Feodor Fitsner on 25 Jul, 2014 04:24 PM

    Feodor Fitsner's Avatar

    I'd give artifact a "deployment name:

    artifacts: 
      - path: deploy\*.zip
        name: mypackage
    

    then use it to locate artifact:

    deploy: 
      - provider: WebDeploy 
        ...
        artifact: mypackage
    
  2. 2 Posted by byron on 25 Jul, 2014 04:29 PM

    byron's Avatar

    Trying now.

  3. 3 Posted by byron on 25 Jul, 2014 04:43 PM

    byron's Avatar

    YES, that was it. Thanks. I'm not sure how I missed that in the documentation. There seem to be a lot of appveyor.yml files in public github repos that are doing it wrong. I was using those as examples.

  4. 4 Posted by daleholborow on 14 Jul, 2015 11:02 PM

    daleholborow's Avatar

    Hi Feodor

    I'm currently struggling to understand the deployment logic. I have in the past created a number of trial projects and had them deploying as webapps to azure (a bizspark account). I later had a two project (angular web and webapi) solution which was also deploying fine, two artifcats, to two websites.

    Now, however, the last two days I have been running into issues in that I use a yml file to configure a new test project for a job that is about to start, and try as i might, I cannot get the "deploy" section to be recognised during the build process. I am looking at my "sssmartadmin" project, and no matter what I do, I check in to my Git repo and the build starts, succeeds, but I see no mention of it being aware of the WebDeploy section of my yaml config? I've attached two files, one from a project I finally got to deploy yesterday (but dont really know why) and the one from today which is based on it, but doesnt work at all (note, I CAN manually deploy to my azure site and it works fine)

  5. Support Staff 5 Posted by Feodor Fitsner on 14 Jul, 2015 11:07 PM

    Feodor Fitsner's Avatar

    What do you have in a build log regarding deployment for sssmartadmin.appveyor.notwork.yml?

  6. 6 Posted by daleholborow on 15 Jul, 2015 01:31 PM

    daleholborow's Avatar

    Morning mate, see attached... as best i can tell, no mention of bundling or deployment there either.

  7. Support Staff 7 Posted by Feodor Fitsner on 15 Jul, 2015 04:41 PM

    Feodor Fitsner's Avatar

    Indeed, deployment is not even mentioned in a build log. OK, make sure that appveyor.yml with deploy section exists in feature/Feature-SA1.7Beta branch as AppVeyor reads it from there.

  8. 8 Posted by daleholborow on 15 Jul, 2015 07:35 PM

    daleholborow's Avatar

    My sincerest apologies Feodor - i had the appveyor sitting in the PROJECT folder, NOT the repo root, the entire time, but was overlooking this because everything still built (after i played around with creating the build settings in the Web UI I guess). Sorry to have taken up your time.

  9. Support Staff 9 Posted by Feodor Fitsner on 15 Jul, 2015 08:04 PM

    Feodor Fitsner's Avatar

    No prob :)

    - Feodor

  10. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:57 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac