Pester Test not showing in Test tab

ducke's Avatar

ducke

16 Jan, 2017 02:32 PM

Hi,
i have a Demo Powershell Module with Pester Test.
Unfortunately no test results are showing on Test tab.

Any kind of help is highly appreciated.

https://ci.appveyor.com/project/ducke/appveyordemo
https://ci.appveyor.com/project/ducke/appveyordemo/build/tests

https://github.com/ducke/AppveyorDemo/blob/master/appveyor.yml

  1. Support Staff 1 Posted by Ilya Finkelshte... on 17 Jan, 2017 08:17 AM

    Ilya Finkelshteyn's Avatar

    It appears to be casing bug in nunit test results parser on our side (PowerShell vs Powershell). Fixing now.

    Temporary workaround can look like this (add this before upload):

    [xml]$content = Get-Content $testResultsFile
    $content.'test-results'.'test-suite'.type = "Powershell"
    $content.Save($testResultsFile)
    

    Ilya.

  2. 2 Posted by ducke on 17 Jan, 2017 11:03 AM

    ducke's Avatar

    Thx Ilya Finkelshteyn,

    Temporary workaround fixed this Problem.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac