Can't RDP to build agent

rami.abughazaleh's Avatar

rami.abughazaleh

25 Jan, 2017 01:25 AM

Hi.

I have enabled RDP during the Init script, and it worked without issue a couple of times.

However, one of the builds today had an RDP server connection address that would not let me connect:

https://ci.appveyor.com/project/icnocop/cuite/build/2.0.343

Remote Desktop connection details:
  Server: 74.205.54.20:34230
  Username: appveyor

When I tried to connect to that address, I got the following error message:
[Window Title]
Remote Desktop Connection

[Content]
Remote Desktop can’t connect to the remote computer for one of these reasons:

1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network

Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.

[OK] [Help]

This connection had a different port number than previous connections, so maybe it has to do with a firewall issue on the build agent?

Thank you.

Showing page 2 out of 2. View the first page

  1. Support Staff 31 Posted by Ilya Finkelshte... on 26 Jul, 2018 10:53 AM

    Ilya Finkelshteyn's Avatar

    Try to rule-out your RDP client or even your computer. Try to connect from another one, or ask you co-workers of friends to connect.

  2. 32 Posted by Everton Fraga on 26 Jul, 2018 01:26 PM

    Everton Fraga's Avatar

    Sure thing, Ilya. Will try.

  3. Support Staff 33 Posted by Ilya Finkelshte... on 26 Jul, 2018 02:27 PM

    Ilya Finkelshteyn's Avatar

    Everton, just to ensure that we are on the same page: build VMs are transient and RDP connection information is actual only during the build. After build VM is destroyed and RDP IP, port and password do not make sense anymore.

  4. 34 Posted by Everton Fraga on 26 Jul, 2018 07:26 PM

    Everton Fraga's Avatar

    Yes, I had put the rdp script at the beginning of the build with that in
    mind.

    And it turns out it worked from a windows host \o/

  5. 35 Posted by Everton on 31 Jul, 2018 06:01 PM

    Everton's Avatar

    Hi again, the proposed solution has been working throughout these days, but I hit another road bump: I can only access RD with auto-generated password, not with any password defined on settings.

    The reason I want to do is quite obvious: I don't want to expose my env variables in a public build that shows-off its RD password.

    The log starts to show only IP+port and username (that's correct), but the password I entered on the settings panel doesn't seem to work for me. Is there anything I can do?

  6. 36 Posted by Everton on 31 Jul, 2018 06:24 PM

    Everton's Avatar

    I managed to log in by declaring my password as secret env variable. yay :)

  7. Support Staff 37 Posted by Ilya Finkelshte... on 31 Jul, 2018 08:40 PM

    Ilya Finkelshteyn's Avatar

    This issue (login problems with password declared in APPVEYOR_RDP_PASSWORD environment variable still can happen intermittently. We are aware and working on it.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac