Can't RDP to build agent

rami.abughazaleh's Avatar


25 Jan, 2017 01:25 AM


I have enabled RDP during the Init script, and it worked without issue a couple of times.

However, one of the builds today had an RDP server connection address that would not let me connect:

Remote Desktop connection details:
  Username: appveyor

When I tried to connect to that address, I got the following error message:
[Window Title]
Remote Desktop Connection

Remote Desktop can’t connect to the remote computer for one of these reasons:

1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network

Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.

[OK] [Help]

This connection had a different port number than previous connections, so maybe it has to do with a firewall issue on the build agent?

Thank you.

  1. 1 Posted by rami.abughazale... on 25 Jan, 2017 11:18 PM

    rami.abughazaleh's Avatar

    Also encountered this issue with in another build

  2. Support Staff 2 Posted by Ilya Finkelshte... on 25 Jan, 2017 11:19 PM

    Ilya Finkelshteyn's Avatar

    Sorry for delay with answer, looking into it.

  3. Support Staff 3 Posted by Feodor Fitsner on 26 Jan, 2017 11:47 PM

    Feodor Fitsner's Avatar

    Hi Rami,

    We double checked our datacenter firewall settings and port mapping. Also we connected with RDP using the same ports. Everything looks OK.

    I wonder if you use blocking RDP. Because if not build might be already finished when you tried to connect. When build finished VM is being decommissioned so this RDP issue is expected.

    In case you are actually using blocking RDP, this might by some intermittent networking issue. Did you try to reconnect?


  4. 4 Posted by rami.abughazale... on 27 Jan, 2017 08:21 PM

    rami.abughazaleh's Avatar

    Hi Feodor,

    Yes, I am setting "$blockRdp = $true;" so the build is waiting for the 'Delete me to continue build.txt' file on Desktop to get deleted before continuing.

    Yes, I have tried to reconnect but still experience the same issue.

    I've also experienced this issue with this RDP connection:

    So far, it seems there's a pattern in that the issue only occurs with ports greater than 34200.
    For example, an RDP connection using port 34151 succeeds.

    I can connect to other servers on those ports from my location without issue.

    Testing with telnet on an inaccessible port:
    >telnet 34201
    Connecting To not open connection to the host, on port 34201: Connect failed

    Testing with telnet to on port 33975 connected without issue.

    Thank you.

  5. Support Staff 5 Posted by Ilya Finkelshte... on 27 Jan, 2017 08:48 PM

    Ilya Finkelshteyn's Avatar


    Can you please prepare you machine by installing WinPcap and TraceTCP and next time you hit this:

    • do not stop build for VM to stay on until build times out.

    • send mail with high importance to [email blocked]. If this happens during work day in PST time zone, we should be able to investigate while VM is in this state.

    • try to trace against problem port to see if some router in between rejects this traffic.


  6. 6 Posted by dmex on 28 Jan, 2017 03:10 PM

    dmex's Avatar


    I'm having the exact same issue with our appveyor builds, the RDP connection is refused when I try connect to the buildbot.

    Also, the email in your post has been blocked and I can't provide information?

  7. Support Staff 7 Posted by Ilya Finkelshte... on 30 Jan, 2017 07:33 PM

    Ilya Finkelshteyn's Avatar

    We need a live repro as we cannot reproduce it ourselves.

    @dmex [email blocked] is not blocked, did you have some issues sending mail to this address?


  8. 8 Posted by ebekker on 31 Jan, 2017 02:54 PM

    ebekker's Avatar

    I'm running into this same issue -- it appears to be happening intermittently, as I ran into it with 2 of my last 3 builds a particular project, but one of the builds was OK.

    I've checked my outgoing firewall settings and attempted from 2 different locations that I know have previously worked before.

    Here is the latest build that is not working:

    Here is the latest build that did work:

  9. Support Staff 9 Posted by Ilya Finkelshte... on 01 Feb, 2017 02:21 AM

    Ilya Finkelshteyn's Avatar

    We recently increased our datacenter capacity and new recently added resources behave this way intermittently. We only localized that this is related to recently added hardware, but we still not fully root cause it. If somebody hit this, please report TCP port not working to this thread.

    Thank you for your patience.


  10. 10 Posted by ebekker on 01 Feb, 2017 03:45 PM

    ebekker's Avatar

    Thanks for the update, will keep an eye on it

  11. 11 Posted by Michael Collins on 15 Mar, 2017 04:02 AM

    Michael Collins's Avatar

    I am hitting this issue tonight with

  12. 12 Posted by Erling on 16 Mar, 2017 09:37 AM

    Erling's Avatar

  13. Support Staff 13 Posted by Ilya Finkelshte... on 18 Mar, 2017 03:01 AM

    Ilya Finkelshteyn's Avatar
  14. 14 Posted by rami.abughazale... on 17 Jul, 2017 10:51 PM

    rami.abughazaleh's Avatar

    Hit this again today.

    Thank you.

  15. Support Staff 15 Posted by Feodor Fitsner on 17 Jul, 2017 11:33 PM

    Feodor Fitsner's Avatar

    Will take a look - thanks for reporting that.

  16. 16 Posted by rami.abughazale... on 18 Jul, 2017 01:47 AM

    rami.abughazaleh's Avatar
  17. 17 Posted by rami.abughazale... on 02 Jan, 2018 12:02 PM

    rami.abughazaleh's Avatar
  18. 18 Posted by pzixel on 17 Jan, 2018 04:30 PM

    pzixel's Avatar
  19. Support Staff 19 Posted by Ilya Finkelshte... on 18 Jan, 2018 03:22 AM

    Ilya Finkelshteyn's Avatar

    Sorry guys. should be fixed now.

  20. 20 Posted by Lukas on 13 Feb, 2018 09:30 PM

    Lukas's Avatar

    Hi, seems like I am having the same problem:

    Thank you!

  21. Support Staff 21 Posted by Ilya Finkelshte... on 13 Feb, 2018 09:44 PM

    Ilya Finkelshteyn's Avatar

    Lukas I just checked it and it works for RDP address in your build. Obviously I have no password but I see that RDP client connected and waiting for me to enter the password. Also error in your screenshots suggests that it is internal and unrelated to network connection to the build machine. I would suggest to retry or try connect from another computer.

  22. 22 Posted by Lukáš Běhal on 20 Feb, 2018 06:07 AM

    Lukáš Běhal's Avatar

    Thanks Ilya. The problem was indeed caused by network connection.

  23. 23 Posted by rami.abughazale... on 26 Mar, 2018 09:23 PM

    rami.abughazaleh's Avatar

    Hitting this issue again

  24. 24 Posted by Michael on 12 Jun, 2018 05:26 AM

    Michael's Avatar

    Seeing the same problem ...


  25. Support Staff 25 Posted by Ilya Finkelshte... on 12 Jun, 2018 04:18 PM

    Ilya Finkelshteyn's Avatar

    @Michael thanks for report. Our fault, side effect of datacenter presence growth. Fixing now. For now, just restart the build and it is very unlikely you will hit this 2 times in a row.

  26. 26 Posted by altendky on 20 Jul, 2018 11:33 AM

    altendky's Avatar

    I've been getting various failures (same as OP, password rejected, and others I think) several times over the past day.

    Specifically, this one is failing right now.

    I'll go ahead and restart again, but that was the second in a row. :] Let me know what debugging info I can provide.


  27. Support Staff 27 Posted by Ilya Finkelshte... on 20 Jul, 2018 05:42 PM

    Ilya Finkelshteyn's Avatar


    We aware of this problem and working it. Meanwhile you can remove APPVEYOR_RDP_PASSWORD environment variable, thus you will be presented with an new random password every time. This is less convenient, but will eliminate password rejected issue for now.


  28. 28 Posted by Everton on 24 Jul, 2018 02:52 PM

    Everton's Avatar

    Me neither. I've tried to connect from Mac with AnyDesk, CoRD, Microsoft Remote; and from windows, using RDC to no avail.

    I can't even telnet to the IP:port provided by the build log.

    for reference, this is my build:

  29. Support Staff 29 Posted by Ilya Finkelshte... on 24 Jul, 2018 05:36 PM

    Ilya Finkelshteyn's Avatar

    @Everton I was able to connect to which is active right now. Are you behind some corporate firewall by any chance?

  30. 30 Posted by Everton Fraga on 26 Jul, 2018 01:47 AM

    Everton Fraga's Avatar

    No, I'm not! I am trying to connect from both home wifi and LTE (to
    rule-out any router config).

    On my latest attempts, I can connect to the IP:port using telnet – but
    still, no RDP. Any clues?

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac