Some unit tests are skipped/not finished

Julien's Avatar

Julien

19 Feb, 2017 06:43 PM

I have strange results with unit tests. Since several days, some tests seems to be skipped. I used to have at least 500 tests running after each build and now I have only around 200 tests. It seems that a specific library is not completely finished. I have made some changes to this library several days ago, but I made only improvement to reduce execution time. I haven't any problem running all tests on my computer and I have checked everything before committing my code.

Here is the build where all tests run correctly : https://ci.appveyor.com/project/Takumii/markify/build/1.0.379. You can see that 528 tests passed and if you look at the log every tests has finished.

Here is the build where tests start to behave strangely : https://ci.appveyor.com/project/Takumii/markify/build/1.0.381. You can see that only 195 tests passed instead of 528. And 195 is not fixed, sometimes it's 205, 219,... For whatever reason some tests seems to be skipped or not finished. If you look at the log you can see that some test library has not finished.

This problem is giving me incorrect and erratic code coverage results since the number of tests runned is always different.

  1. 1 Posted by Julien on 19 Feb, 2017 07:14 PM

    Julien's Avatar

    I had investigate and if I look at the unit tests result page, I can see that some unit tests are not green but yellow and blinking like if they are still running. But depending on the build, it's not always the same tests.

  2. Support Staff 2 Posted by Feodor Fitsner on 20 Feb, 2017 12:44 AM

    Feodor Fitsner's Avatar

    Will investigate. Thanks for reporting!

  3. 3 Posted by Julien on 07 Mar, 2017 10:05 PM

    Julien's Avatar

    Any news about this issue?

  4. 4 Posted by Felix Schröter on 15 Mar, 2017 03:39 PM

    Felix Schröter's Avatar

    I'm having the same/similar issue.
    My build was successful and the log states no failed or skipped tests but when going to the Tests tab on the AppVeyor website some are marked yellow.
    Also, no duration is shown for those tests.

    https://ci.appveyor.com/project/FelschR/aspnetcore-identity-documentdb/build/0.3.0-beta-master-13/tests

  5. Support Staff 5 Posted by Ilya Finkelshte... on 16 Mar, 2017 02:45 AM

    Ilya Finkelshteyn's Avatar

    We are working on it, please watch this GitHub issue.

  6. 6 Posted by Julien on 27 Mar, 2017 09:38 AM

    Julien's Avatar

    I can see that a fix has been provided the 20th March for the bug #1401. But I still have problems with unit tests, some are stuck and they are never finished (https://ci.appveyor.com/project/Takumii/markify/build/1.0.396/tests).

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac