Added a Visual Studio Install Project and now and getting errors during build.

eric's Avatar

eric

05 Aug, 2014 11:18 AM

I added an Installer project to my solution:

https://ci.appveyor.com/project/efontana/timberwinr/history
https://github.com/efontana/TimberWinR/tree/master/Installer

And when the project builds now I get this error:

Build started
2git clone -q --branch=master https://github.com/efontana/TimberWinR.git C:\projects\timberwinr
3git checkout -qf 28d45a9e996ce70f6c7870521f1682534a5f415f
4Project file "Installer.vdproj" is not a valid MSBuild project file which must be an XML.

How do I get around this or simply disable that part from being built?

  1. Support Staff 1 Posted by Feodor Fitsner on 05 Aug, 2014 11:35 AM

    Feodor Fitsner's Avatar

    That's correct, vdproj is not supported by msbuild, it's not even an XML. Microsoft just backported original Web and Deployment projects to VS 2013. The only known hack to build vdproj on a server was calling devenv.exe, but AppVeyor build workers have Visual Studio Express editions installed which don't have devenv.exe.

    I would switch to WiX - vdproj doesn't provide any complex functionality and it could be ported to WiX in hours. There are tons of ready WiX projects on GitHub that can be used as a sample.

  2. 2 Posted by eric on 07 Aug, 2014 05:47 PM

    eric's Avatar

    I've used WiX before, didn't care much for it, my real question is how do I tell
    AppVeyor to ignore this project? At the moment nothing will build because it's seeing the .vdproj file, is there a way to ignore/disable the Installer project?

  3. Support Staff 3 Posted by Feodor Fitsner on 07 Aug, 2014 05:55 PM

    Feodor Fitsner's Avatar

    Open solution's Configuration Manager in Visual Studio and disable that project from build for required configuration.

    Also, set TimberWinR.sln as project on Build tab of project settings.

  4. 4 Posted by eric on 08 Aug, 2014 06:36 PM

    eric's Avatar

    Hi, I bit the bullet and added a Wix project, but it doesn't get built? I looked through the
    docs and don't see any way to enable it?

    It is selected to be built in all configurations.

    What am I missing.

    Thanks.

  5. Support Staff 5 Posted by Feodor Fitsner on 08 Aug, 2014 09:44 PM

    Feodor Fitsner's Avatar

    Hi Eric,

    You mean you have WiX project enabled on solution's Configuration Manager and it still doesn't get built? Have you tried building that solution locally. Make sure that it's enabled in correct configuration and it's set on build settings.

  6. 6 Posted by eric on 08 Aug, 2014 10:49 PM

    eric's Avatar

    That's correct it builds
    Fine locally both release and debug
    Nothing happens in appveyor

    Sent from my iPhone

  7. Support Staff 7 Posted by Feodor Fitsner on 08 Aug, 2014 11:09 PM

    Feodor Fitsner's Avatar

    Are you getting any errors?

    - Feodor

  8. 8 Posted by eric on 09 Aug, 2014 12:07 AM

    eric's Avatar

    Nope it just doesn't build
    The wiz project
    It builds the app and runs tests
    And nuget

    No wix

    Sent from my iPhone

  9. Support Staff 9 Posted by Feodor Fitsner on 09 Aug, 2014 12:09 AM

    Feodor Fitsner's Avatar

    OK, will take a look.

  10. Support Staff 10 Posted by Feodor Fitsner on 09 Aug, 2014 12:37 AM

    Feodor Fitsner's Avatar

    I've made a simple test solution with WiX installer: https://github.com/FeodorFitsner/wix-test
    Building WiX project works: https://ci.appveyor.com/project/appvyr/wix-test/build/1.0.2

    Most probably, it's just not visible in your log because there is "Minimal" log verbosity.

  11. 11 Posted by eric on 14 Aug, 2014 01:16 PM

    eric's Avatar

    Awesome! Thanks for the great support, one last question, is there a nice way
    to rename the generated .msi file to contain the version number?

  12. Support Staff 12 Posted by Feodor Fitsner on 14 Aug, 2014 03:09 PM

    Feodor Fitsner's Avatar

    I think you can do this in PowerShell in "after build" section, or you can have a different file name in cloud storage while pushing artifact: http://www.appveyor.com/docs/build-worker-api#push-artifact

  13. 13 Posted by Tom Moriarty on 24 Jun, 2015 09:52 PM

    Tom Moriarty's Avatar

    We recently received an error when trying to build our Visual Studio 2013 solution which contained a Visual Studio Installer Project. The error was: "Project file "BillingServiceInstall.vdproj" is not a valid MSBuild project file which must be an XML." See the following link: https://ci.appveyor.com/project/toolwatch/tw-soap-1tau3 .

    Is there any way to update the AppVeyor Visual Studio 2013 environment to support the latest Visual Studio Installer project recently released by Microsoft? I realize that WIX is a viable alternative but replacing our Visual Studio 2013 installer projects with WIX would take a significant amount of development time and effort.

    Microsoft seems to be serious about supporting Visual Studio Installer Projects in 2013 and 2015. See https://visualstudiogallery.msdn.microsoft.com/9abe329c-9bba-44a1-be59-0fbf6151054d

  14. Support Staff 14 Posted by Feodor Fitsner on 25 Jun, 2015 03:01 AM

    Feodor Fitsner's Avatar

    That extension for vdproj is already installed on build workers. You just need to use devenv.exe (full path is "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\devenv.exe") to build your .vdproj or solution file: https://social.msdn.microsoft.com/Forums/windows/en-us/0ec5951d-d19...

  15. 15 Posted by buhleloisarto on 18 Jan, 2018 06:57 AM

    buhleloisarto's Avatar

    Hello, I am too late but I just got a page that can solve some project files issues. I am not sure it is helpful or not for your question because our project file issues are different. Here for you http://www.videoconverterfactory.com/tips/vproj-to-mp4.html

  16. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:26 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac