dotnet test stops without error message in appveyor

Viktor Hofer's Avatar

Viktor Hofer

15 Mar, 2017 01:39 PM

Hey there, in my test_script I use dotnet test X.csproj to test my assembly with appveyor. Sometimes it is working, sometimes it is not and appveyor stops immediately without any error message:

Starting test execution, please wait...
[xUnit.net 00:00:00.6405421] Discovering: Prism.Tests
[xUnit.net 00:00:00.9129221] Discovered: Prism.Tests
[xUnit.net 00:00:00.9865457] Starting: Prism.Tests

https://ci.appveyor.com/project/ViktorHofer/prism/build/1.0.22

I know that this is also related to dotnet-cli and xunit but maybe there are also some error on the appveyor side? It is stopping without any error message...

  1. 1 Posted by Viktor Hofer on 15 Mar, 2017 01:48 PM

    Viktor Hofer's Avatar

    And my current dotnet-cli tools are: .NET Command Line Tools (1.0.0)
    How do I get to 1.0.1 with Visual Studio 2017 environment?

  2. Support Staff 2 Posted by Ilya Finkelshte... on 16 Mar, 2017 01:49 AM

    Ilya Finkelshteyn's Avatar

    Hi Victor,

    If you use UI, please set build worker image to Visual Studio 2017 in Settings > Environment, or if you use YAML, add image: Visual Studio 2017 to it.

    Let us know if this helps.

    Ilya.

  3. 3 Posted by Viktor Hofer on 16 Mar, 2017 02:15 AM

    Viktor Hofer's Avatar

    Hey,

    image Visual Studio 2017 is already my current setting!

  4. Support Staff 4 Posted by Ilya Finkelshte... on 17 Mar, 2017 01:20 AM

    Ilya Finkelshteyn's Avatar

    Hi Viktor,

    Sorry I should have look at your appveyor.yml first, my bad. What you observe is another manifestation of this GH issue. We are working on it right now.

    Ilya.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac