No packages were published

Mauro Sampietro's Avatar

Mauro Sampietro

20 Apr, 2017 03:19 PM

I configured the deployment section in my project's settings, and exported the yaml and added to the root of my project.
I'm sorry, i can't get my package published on Nuget.
Any help?

  1. 1 Posted by Ilya Finkelshte... on 20 Apr, 2017 04:33 PM

    Ilya Finkelshteyn's Avatar

    Hi Mauro,

    You need to make 2 changes:

    • Add nuget packaging statement to your YAML file, like this:
      publish_nuget: true  
      verbosity: minimal
    • Have .nuspec file side by side with respective project, not solution. For your project this means moving UltraMapper.nuspec from the root to UltraMapper folder.


  2. 2 Posted by mauro sampietro on 27 Apr, 2017 01:47 PM

    mauro sampietro's Avatar

    I did as you said and the problem was fixed, but i had to write a specific
    number version in the nuspec file in order to build/publish "0.1.23".

    I noticed i cannot leave {build} in my nuspec file because when building
    appveyor tell me the following, but still I'd like appveyor to
    manage/update the version for me:

    *'0.1.{build}' is not a valid version string.*
    name: value*

    exited with code 1*

    What i'm doing wrong? How can i achieve auto update of the version in the
    nuspec file?


  3. 3 Posted by Ilya Finkelshte... on 27 Apr, 2017 07:41 PM

    Ilya Finkelshteyn's Avatar

    Hi Mauro,

    • Enable AssemblyInfo patching
    • Ensure AssemblyInfo.cs file contains AssemblyInformationalVersion tag (by default it might not)
    • Ensure that at .nuspec file version value is set to $version$

    Additional info


  4. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:16 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac