After upgrading some Nuget packages, i'm getting an error

Christian's Avatar

Christian

20 Apr, 2017 04:31 PM

After upgrading some Nuget packages, i'm getting this error:
'Newtonsoft.Json' already has a dependency defined for 'Microsoft.CSharp'.
Command exited with code 1

This is the full stack:
Build started
Fetching repository commit (5472b70)...OK
Total: 358.4 MB in 7063 files
nuget restore %solution_name%.sln
Installing 'Newtonsoft.Json 10.0.2'.
Installing 'Microsoft.SqlServer.Scripting 11.0.2100.61'.
Installing 'RestSharp 105.2.3'.
Successfully installed 'Microsoft.SqlServer.Scripting 11.0.2100.61'.
Successfully installed 'RestSharp 105.2.3'.
Installing 'Microsoft.AspNet.Identity.Owin 2.2.1'.
Installing 'Microsoft.AspNet.Identity.Core 2.2.1'.
Installing 'Microsoft.Owin 3.1.0'.
Successfully installed 'Microsoft.AspNet.Identity.Owin 2.2.1'.
Successfully installed 'Microsoft.AspNet.Identity.Core 2.2.1'.
Successfully installed 'Microsoft.Owin 3.1.0'.
Installing 'Microsoft.Owin.Security.Cookies 3.1.0'.
Installing 'Microsoft.Owin.Security.OAuth 3.1.0'.
Installing 'Microsoft.Owin.Security 3.1.0'.
Successfully installed 'Microsoft.Owin.Security.Cookies 3.1.0'.
Successfully installed 'Microsoft.Owin.Security.OAuth 3.1.0'.
Installing 'Owin 1.0'.
Successfully installed 'Owin 1.0'.
Successfully installed 'Microsoft.Owin.Security 3.1.0'.
Installing 'AWSSDK.Core 3.3.12'.
Installing 'AWSSDK.EC2 3.3.13'.
Installing 'AWSSDK.S3 3.3.5.12'.
Successfully installed 'AWSSDK.S3 3.3.5.12'.
Installing 'AWSSDK.SimpleDB 3.3.0.12'.
Installing 'EntityFramework 6.1.3'.
Successfully installed 'AWSSDK.SimpleDB 3.3.0.12'.
Successfully installed 'AWSSDK.Core 3.3.12'.
Installing 'EPPlus 4.1.0'.
Installing 'HtmlAgilityPack 1.4.9.5'.
Successfully installed 'EPPlus 4.1.0'.
Installing 'Microsoft.AspNet.Identity.EntityFramework 2.2.1'.
Successfully installed 'Microsoft.AspNet.Identity.EntityFramework 2.2.1'.
Successfully installed 'EntityFramework 6.1.3'.
Installing 'Microsoft.AspNet.Razor 3.2.3'.
Successfully installed 'HtmlAgilityPack 1.4.9.5'.
Installing 'Microsoft.AspNet.Mvc 5.2.3'.
Installing 'Microsoft.AspNet.WebPages 3.2.3'.
Successfully installed 'Microsoft.AspNet.Razor 3.2.3'.
Successfully installed 'Microsoft.AspNet.Mvc 5.2.3'.
Successfully installed 'Microsoft.AspNet.WebPages 3.2.3'.
Installing 'Microsoft.Report.Viewer 11.0.0.0'.
Installing 'Microsoft.SqlServer.Types 14.0.314.76'.
Installing 'Microsoft.Web.Infrastructure 1.0.0.0'.
Successfully installed 'Microsoft.Web.Infrastructure 1.0.0.0'.
Installing 'System.Data.SQLite 1.0.105.0'.
Successfully installed 'System.Data.SQLite 1.0.105.0'.
Installing 'System.Data.SQLite.Core 1.0.105.0'.
Installing 'System.Data.SQLite.EF6 1.0.105.0'.
Successfully installed 'AWSSDK.EC2 3.3.13'.
Installing 'System.Data.SQLite.Linq 1.0.105.0'.
Successfully installed 'System.Data.SQLite.Linq 1.0.105.0'.
Installing 'Antlr 3.5.0.2'.
Successfully installed 'Microsoft.Report.Viewer 11.0.0.0'.
Installing 'jQuery 2.2.3'.
Successfully installed 'Antlr 3.5.0.2'.
Successfully installed 'Microsoft.SqlServer.Types 14.0.314.76'.
Installing 'knockoutjs 3.4.2'.
Installing 'Microsoft.AspNet.Cors 5.2.3'.
Successfully installed 'System.Data.SQLite.EF6 1.0.105.0'.
Successfully installed 'jQuery 2.2.3'.
Successfully installed 'knockoutjs 3.4.2'.
Successfully installed 'Microsoft.AspNet.Cors 5.2.3'.
Installing 'Microsoft.AspNet.Providers 2.0.0'.
Installing 'Microsoft.AspNet.Web.Optimization 1.1.3'.
Installing 'Microsoft.AspNet.WebApi.Client 5.2.3'.
Installing 'Microsoft.AspNet.Providers.Core 2.0.0'.
Successfully installed 'Microsoft.AspNet.Providers 2.0.0'.
Successfully installed 'Microsoft.AspNet.Web.Optimization 1.1.3'.
Successfully installed 'Microsoft.AspNet.Providers.Core 2.0.0'.
Successfully installed 'Microsoft.AspNet.WebApi.Client 5.2.3'.
Installing 'Microsoft.AspNet.WebApi.Cors 5.2.3'.
Installing 'Microsoft.AspNet.WebApi.Core 5.2.3'.
Successfully installed 'Microsoft.AspNet.WebApi.Cors 5.2.3'.
Installing 'Microsoft.Owin.Cors 3.1.0'.
Installing 'Microsoft.AspNet.WebApi.WebHost 5.2.3'.
Successfully installed 'Microsoft.AspNet.WebApi.Core 5.2.3'.
Successfully installed 'Microsoft.Owin.Cors 3.1.0'.
Installing 'Microsoft.Owin.Host.SystemWeb 3.1.0'.
Successfully installed 'System.Data.SQLite.Core 1.0.105.0'.
Successfully installed 'Microsoft.Owin.Host.SystemWeb 3.1.0'.
Successfully installed 'Microsoft.AspNet.WebApi.WebHost 5.2.3'.
Installing 'modernhttpclient 2.4.2'.
Installing 'Modernizr 2.8.3'.
Installing 'OpenPop.NET 2.0.6.1120'.
Installing 'Stripe.net 8.1.1'.
Installing 'WebGrease 1.6.0'.
Successfully installed 'Modernizr 2.8.3'.
Successfully installed 'OpenPop.NET 2.0.6.1120'.
Successfully installed 'Stripe.net 8.1.1'.
Successfully installed 'WebGrease 1.6.0'.
Successfully installed 'modernhttpclient 2.4.2'.
Installing 'ClearScript.V8 5.4.9'.
Successfully installed 'ClearScript.V8 5.4.9'.
'Newtonsoft.Json' already has a dependency defined for 'Microsoft.CSharp'.
Command exited with code 1

  1. Support Staff 1 Posted by Ilya Finkelshte... on 20 Apr, 2017 04:38 PM

    Ilya Finkelshteyn's Avatar

    Hello Christian,

    Does nuget restore <you_solution_name>.sln works fro you locally now? And if yes, what nuget version do you use?

    Thanks!
    Ilya.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac