Protractor - webdriver-manager update fails due to Github API limits

joymon's Avatar

joymon

09 May, 2017 08:44 PM

Hi There,
Thanks for providing wonderful free hosted CI&CD for open source. The issue below seems more towards WebDriver-Manager which is in discussion at
https://github.com/angular/webdriver-manager/issues/216

I am trying to use protractor for e2e testing of my angular js app with CI. It requires 'webdriver-manager update' command before running the tests. It works in my dev machine but never in AppVeyor CI due to GitHubAPI limits. Seems the command is trying to hit GitHub API to download something which has limits.

Tried to update standalone as mentioned below. But didnt work
https://github.com/FeodorFitsner/AppVeyor-Protractor-test-app/blob/master/package.json

My CI logs url is below which has issue (line 1225)
https://ci.appveyor.com/project/joymon/webpack-starters

Please help if there are any known workaround.

  1. Support Staff 1 Posted by Feodor Fitsner on 09 May, 2017 08:53 PM

    Feodor Fitsner's Avatar

    Do you have a link to a build where you tried webdriver-manager update command?

  2. 2 Posted by joymon on 09 May, 2017 09:13 PM

    joymon's Avatar

    https://ci.appveyor.com/project/joymon/webpack-starters
    Git repo - github.com/joymon/webpack-starters

    It uses appveyor.yml for everything.

  3. Support Staff 3 Posted by Feodor Fitsner on 09 May, 2017 09:56 PM

    Feodor Fitsner's Avatar

    webdriver-manager update --gecko false worked: https://github.com/FeodorFitsner/webpack-starters/blob/master/TypeS...

    Build results: https://ci.appveyor.com/project/FeodorFitsner/webpack-starters/buil...

    Sources:

    Alternatively, if you need Gecko it looks like there is a way to save JSON with releases (I don't know yet how) information and then pass it to webdriver-manager in --out_dir parameter.

  4. 4 Posted by joymon on 10 May, 2017 02:03 PM

    joymon's Avatar

    Thats really quick. For now I can live without Gecko :)
    Once again thanks for your freemium service and support.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac