Error on call to GitVersion.AppVeyor.GenerateSetVersionMessage()

José Simões's Avatar

José Simões

11 Oct, 2017 12:09 PM

Hi,

I'm seeing this error on the build script that is preventing the proper setting of the version variables.
Do I need to change anything on my script?

https://ci.appveyor.com/project/nfbot/nf-interpreter/build/1.0.237-owcdnphe

Thanks,

  1. Support Staff 1 Posted by Ilya Finkelshte... on 20 Oct, 2017 09:31 PM

    Ilya Finkelshteyn's Avatar

    Sorry for delay with answer. I am not sure that I understand the whole workflow, but I think that this is related to the fact that secure variable are not available in pull requests.
    Because of security concerns, for open source projects we have an option to enable secure variables for pull requests only from the same repository.

  2. 2 Posted by José Simões on 21 Oct, 2017 07:59 AM

    José Simões's Avatar

    This error (GenerateSetVersionMessage) is showing around line 136.
    Plase check the log and you’ll find it there.
    From what I understand of the call stack there it seems that the script is trying to perform and HTTP request to the build server and that is failing. I’m guessing that’s trying to update an env var and that it’s failing.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

22 Oct, 2017 04:20 AM
21 Oct, 2017 07:26 PM
21 Oct, 2017 10:08 AM
21 Oct, 2017 07:59 AM
21 Oct, 2017 01:48 AM