Illegal characters in paths

Sergey's Avatar

Sergey

18 Oct, 2017 05:49 AM

Pulled up an old project which used Visual Studio 2013 build worker image. Updated the code to use null-coalescing operator in part of the code and updated build worker image to Visual Studio 2015. Tried building the project but this is what i get now:

```
Build started
git clone -q --branch=master https://github.com/blah/blah.git C:\Projects\blah
git checkout -qf 0df6ce28308ce675e35cb3261f94cd7e9ecb7c64
Illegal characters in path.
```

This is somewhat baffling. Where do i go from here?

  1. Support Staff 1 Posted by Ilya Finkelshte... on 18 Oct, 2017 08:21 AM

    Ilya Finkelshteyn's Avatar

    I think I found your project and I do not see that you updated build worker image to Visual Studio 2015 in your appveyor.yml. If you did this in UI, please be aware that appveyor.yml takes over UI: https://www.appveyor.com/docs/build-configuration/#appveyoryml-and-...

  2. 2 Posted by Sergey on 18 Oct, 2017 02:07 PM

    Sergey's Avatar

    I understand. I ignored appveyor.yml in appveyor project settings and changed the Visual Studio image from the dashboard. The project at least starts the build in VS 2013 and then just chokes on new C# features. Changing to VS 2015 throws the above error. This is really looking like an appveyor bug.

  3. 3 Posted by Sergey on 18 Oct, 2017 02:10 PM

    Sergey's Avatar

    FYI, the project builds just fine in VS 2015. Both git operations are also working fine locally. So I don't exactly understand what's throwing this error.

  4. Support Staff 4 Posted by Ilya Finkelshte... on 18 Oct, 2017 07:44 PM

    Ilya Finkelshteyn's Avatar

    I forked your repo, changed VS 2013 to VS 2015 and it builds OK.

    Then I reverted back to VS 2013 and it fails with modern C# syntax related errors as expected.

    When you set ignore appveyor.yml, all your UI settings apply. It must be something in your UI settings which makes AppVeyor fail. To get help in understanding that you can press Export YAML in UI and send results here.

  5. 5 Posted by Sergey on 19 Oct, 2017 02:23 AM

    Sergey's Avatar

    You're absolutely right. Simply updating appveyor worked. I'll see how the console settings are different. Thanks for you help!

  6. Support Staff 6 Posted by Ilya Finkelshte... on 19 Oct, 2017 02:25 AM

    Ilya Finkelshteyn's Avatar

    Good, thanks for update!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac