Tests fail on AppVeyor but not locally.

matt.hamilton.2383's Avatar


25 Oct, 2014 10:05 PM

My project here: https://ci.appveyor.com/project/mthamil/plantumlstudio/build/tests, has a couple failing tests (one is a data driven test so each case has an entry). I have never had any problems running them in Visual Studio, but just in case, I ran them locally using the same version of the xUnit.net console runner. No failures. I also tried each build configuration. I can't think of any other reason for these differences. The non-data driven test failure dealing with OperationCanceledException vs TaskCanceledException is particularly strange to me and almost suggests a .NET framework difference. Does anyone have any ideas?

Showing page 2 out of 2. View the first page

  1. 30 Posted by Darren Wood on 24 Jan, 2017 02:33 AM

    Darren Wood's Avatar

    https://ci.appveyor.com/project/DarrenWood/transmax fails 2 out of 5 tests but passes locally. Any ideas as to why it is failing. The expected and actual strings it is comparing seem to be the same in the Assert.Equal.

  2. 31 Posted by Ilya Finkelshte... on 24 Jan, 2017 06:56 PM

    Ilya Finkelshteyn's Avatar

    @Darren Wood: sent you PR with the fix. Problem is that "expected" variable had \n as a new line instead of \r\n


  3. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:14 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac