VS2017 image missing SSDT Reporting Services

blaw's Avatar


02 Nov, 2017 05:52 PM

After upgrading to VS2017 for SSDT project, and setting appveyor.yml to use the VS2017 image, AppVeyor is no longer able to build reporting services projects (.rptproj)

Locally, I'm using SSDT for VS2017 (14.0.16134.0) downloaded from here: https://docs.microsoft.com/en-us/sql/ssdt/download-sql-server-data-tools-ssdt#ssdt-for-visual-studio-2017

When installing SSDT for VS2017, I had make sure Reporting Services components are install.

00:00:29] Project "C:\projects\fleetcarmadb\FleetCarmaDB.sln" (1) is building "C:\projects\fleetcarmadb\FleetCarma.SSRS\FleetCarma.SSRS.rptproj" (3) on node 1 (default targets).
[00:00:29] C:\projects\fleetcarmadb\FleetCarma.SSRS\FleetCarma.SSRS.rptproj(67,11): error MSB4226: The imported project "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\Reporting Services\Microsoft.ReportingServices.MSBuilder.targets" was not found. Also, tried to find "Reporting Services\Microsoft.ReportingServices.MSBuilder.targets" in the fallback search path(s) for $(MSBuildExtensionsPath) - "C:\Program Files (x86)\MSBuild" . These search paths are defined in "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\Bin\MSBuild.exe.Config". Confirm that the path in the <Import> declaration is correct, and that the file exists on disk in one of the search paths.
[00:00:29] Done Building Project "C:\projects\fleetcarmadb\FleetCarma.SSRS\FleetCarma.SSRS.rptproj" (default targets) -- FAILED.

  1. Support Staff 1 Posted by Feodor Fitsner on 02 Nov, 2017 06:06 PM

    Feodor Fitsner's Avatar

    Looking at release notes for SSDT for VS 2017 I'm getting confused a little bit - is it for VS 2017 15.4 Preview or SSDT itself in "preview"? My main concern whether it's safe to deploy it to an image with VS 2017.

  2. 2 Posted by blaw on 03 Nov, 2017 02:32 AM

    blaw's Avatar

    That's a great question and you raised a very good point. It looks like SSDT for VS2017 15.X is in preview because localization is not ready.

    Alternatively, reporting service tools is released as VS extension and it isn't in preview.

    Is this something that could be included in the image?

  3. 3 Posted by blaw on 06 Nov, 2017 04:44 PM

    blaw's Avatar

    Hey Feodor, do you have any recommendation that can unblock us from building 2017 SSRS projects on appveyor?

  4. Support Staff 4 Posted by Feodor Fitsner on 06 Nov, 2017 05:31 PM

    Feodor Fitsner's Avatar

    You can use the following script to install SSDT extension into VS 2017 during install phase:

    Write-Host "Downloading ReportingServices VSIX..."
    $vsixPath = "$env:TEMP\Microsoft.DataTools.ReportingServices.vsix"
    (New-Object Net.WebClient).DownloadFile('https://visualstudiogallery.msdn.microsoft.com/85e42f76-6afa-4a68-afb5-033d1fe08d7b/file/251615/8/Microsoft.DataTools.ReportingServices.vsix', $vsixPath)
    Write-Host "Installing..."
    "`"C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VSIXInstaller.exe`" /q /a $vsixPath" | out-file ".\install-vsix.cmd" -Encoding ASCII
    & .\install-vsix.cmd

    I've added a new issue to install SSDT for VS 2017: https://github.com/appveyor/ci/issues/1902

  5. 5 Posted by blaw on 09 Jan, 2018 04:07 PM

    blaw's Avatar

    Feodor, is the new SSDT / SSRS extension included in the current VS 2017 image? I don't see it in the doc yet https://www.appveyor.com/docs/build-environment/#pre-installed-software

  6. 6 Posted by blaw on 10 Jan, 2018 07:17 PM

    blaw's Avatar

    I tried using the VS 2017 Preview image and it has all the components needed for SSRS built in. Any idea when VS2017 Preview will be promoted to the normal build?

  7. Support Staff 7 Posted by Feodor Fitsner on 11 Jan, 2018 05:39 AM

    Feodor Fitsner's Avatar

    Looks like it's out of preview state. I've created a new issue: https://github.com/appveyor/ci/issues/2020

    Will see if it can be pushed during the next update.

  8. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:26 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac