Random Error: read ECONNRESET when uploading release to GitHub

Laurent's Avatar

Laurent

13 Nov, 2017 03:49 PM

I'm getting random "Error: read ECONNRESET" errors when uploading releases to GitHub via electron-builder. It worked for some time but now it seems to happen on most builds, for example: https://ci.appveyor.com/project/laurent22/joplin/build/1.0.30.master

Any idea what could be causing this? I assume it's not GitHub that is blocking the upload?

  1. Support Staff 1 Posted by Ilya Finkelshte... on 14 Nov, 2017 07:12 PM

    Ilya Finkelshteyn's Avatar

    Hi Laurent,

    From the first look, it looks like network connection issues between AppVeyor build workers and GitHub. But we see that those errors happens regardless of the datacenter build worker VM located in (we have infrastructure in 2 different datacenters). GitHub status is OK. Also network issue do not come with single problem, usually this affects bigger number of people.

    Therefore we need to look at your settings. If I understand correctly, you are following this guide, right? And the only setting you specify is this, correct? Sorry in advance I am not familiar with this publishing. How do you specify GH_TOKEN, in UI?

    Ilya.

  2. 2 Posted by Laurent on 14 Nov, 2017 08:39 PM

    Laurent's Avatar

    Hi Ilya,

    Thanks your answer. To deploy I indeed use electron-builder with mostly the default config. For GH_TOKEN, I provide it in the Project Settings of AppVeyor, in the Environment page.

    I don't think my code is doing anything special and electron-builder does the upload using the standard https package of node: see here so I'm not sure what could be the issue.

    I should note that the past 7 builds have worked successfully so maybe it was a temporary thing. Another thing is that I use node a lot under WSL and I get all kind of random network errors which don't happen in other environments. I don't know if it's something wrong with MS's network stack or node, but maybe it's what's happening here too?

  3. Support Staff 3 Posted by Ilya Finkelshte... on 15 Nov, 2017 02:23 AM

    Ilya Finkelshteyn's Avatar

    Lets see how it will work next few days in hope this was temporary network issue which was not detected by our monitoring and other customers.

    I an little bit confused regarding WSL though. It stands for Windows Subsystem for Linux, right? We do not have it on our build workers (Windows Server 2012 and 2016). It is currently available only on Windows 10 or Windows Server Insider's preview and we will make it available as soon as it is available on official Windows Server release...

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Nov, 2017 01:23 PM
23 Nov, 2017 11:10 AM
23 Nov, 2017 10:33 AM
22 Nov, 2017 11:31 PM
22 Nov, 2017 06:44 PM

 

22 Nov, 2017 05:27 PM
22 Nov, 2017 10:12 AM
22 Nov, 2017 03:23 AM
22 Nov, 2017 12:47 AM
21 Nov, 2017 09:15 PM
21 Nov, 2017 06:18 AM