Copy NuGet package to artifacts and publish to

Dave senn's Avatar

Dave senn

15 May, 2015 02:46 PM

Unfortunately I’ve to ask for help again.
I’m working on an opensource .net library (,
My library has a NuGet package (
Until now I created and uploaded the package manually to
Now I try to automat this process using the NuGet deploy feature of appveyor.

I use the ‘before_deploy’ script to create the NuGet package using nuget.exe.
The first problem:
My script ( reads the version and other properties from the freshly built dll. (Appveyor should patch the version) But in the output of my script I can see that the version was not patched. (Wenn I download the artifacts the version of the DLL is also not patched.)

Second Problem:
I can’t figure out how to copy the generated NuGet package to the Artifacts.
I tried it with '**\*.nupkg' and 'Nuget\*.nupkg'. (The first copies only the NUnit package, the second does not copy anything).

So my questions:
- How can I fix the problem with patching the assembly information?
- How can I copy the generated NuGet package to the artifacts?

Sorry for asking you all this questions… but I can’t find a way to get it running.

  1. Support Staff 1 Posted by Feodor Fitsner on 15 May, 2015 11:38 PM

    Feodor Fitsner's Avatar

    Regarding assembly patching - looks like AppVeyor doesn't "like" spaces around version value in "AssemblyVersion( "" )". Will add an issue to fix that shameless mistake :)

    I think the right time to call PS generating nuget packages is "after_build". Then 'nuget\*.nupkg' in artifact definition looks correct.

    - Feodor

  2. 2 Posted by Dave Senn on 16 May, 2015 12:25 PM

    Dave Senn's Avatar

    Thank you very much for your help.
    I’ve removed the spaces (just for testing) and fixed my script (NuGet package was not created in \NuGet)… now it works.


  3. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:56 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac