Nunit 3.8 Support

richard.chapman's Avatar

richard.chapman

10 Nov, 2017 02:07 PM

Hi

We just upgraded our app to .NET 4.7 and everything built ok.
The build pulls in Nunit 3.8.1(Restoring NuGet package NUnit.3.8.1) but then uses the NUnit 3.6 runner.

NUnit Console Runner 3.6.1
Copyright (C) 2017 Charlie Poole
Runtime Environment
   OS Version: Microsoft Windows NT 6.3.9600.0
  CLR Version: 4.0.30319.42000
Test Files
    C:\projects\notifications-net-client\NotifyTests\bin\Debug\NotifyTests.dll
Test Filters
    Where: cat == Unit/AuthenticationTests || cat == Unit/NotificationClient || cat == Integration
Errors, Failures and Warnings
1) Error :
Could not load file or assembly 'nunit.framework' or one of its dependencies. The system cannot find the file specified.

Can we change to 3.8 runner if not when will you support it.

Thanks

  1. Support Staff 1 Posted by Ilya Finkelshte... on 10 Nov, 2017 08:53 PM

    Ilya Finkelshteyn's Avatar

    Hi Richard,

    Could you please help us with a repro? I tried to reproduce in this build, but could not.

    Also I am little bit surprised how it builds OK after upgrade to .NET 4.7, while this issue is still open.

    Anyway I filed issue to update NUnit.

  2. 2 Posted by richard.chapman on 14 Nov, 2017 10:31 AM

    richard.chapman's Avatar
  3. Support Staff 3 Posted by Ilya Finkelshte... on 15 Nov, 2017 02:34 AM

    Ilya Finkelshteyn's Avatar

    Hi Richard,

    I could not find the build with version 1.0.646, maybe you deleted it? Anyway I see that it works now for you. Could you please clarify if it fixed and if yes, what was the actual problem?

    Side question: why do you connect your project to AppVeyor as a generic Git instead of GitHub? With this approach you are loosing number of benefits of AppVeyor/GitHub integration, such as appveyor.yml, pull requests, tags support and many more...

    Ilya.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Nov, 2017 01:23 PM
23 Nov, 2017 11:10 AM
23 Nov, 2017 10:33 AM
22 Nov, 2017 11:31 PM
22 Nov, 2017 06:44 PM

 

22 Nov, 2017 05:27 PM
22 Nov, 2017 10:12 AM
22 Nov, 2017 03:23 AM
22 Nov, 2017 12:47 AM
21 Nov, 2017 09:15 PM
21 Nov, 2017 06:18 AM