Build tag annotation overwritten

trevor.sandy's Avatar

trevor.sandy

02 Jan, 2018 01:02 PM

Is it possible to not overwrite the tag's annotation with the commit message when deploying using the GitHub provider?

Log snippit:

Deploying using GitHub provider
Creating "v2.1.0_beta1" release for repository "[redacted]" tag "v2.1.0_beta1" commit "a46c63570138ac5b7b4bbf92766fddf0592b3fc0"...Skipped - release with tag "v2.1.0_beta1" already exists
Uploading [redacted] to release assets...OK
Updating "v2.1.0_beta1" release for repository "[redacted]" tag "v2.1.0_beta1" commit "a46c63570138ac5b7b4bbf92766fddf0592b3fc0"...OK
Action:
  • Post commit with message 'Update changelog'
  • 'Draft a new release' from the GitHub web UI - with the annotation 'v2.1.0_beta1 - skip Sourceforge deploy' Expectation:
  • Successful deploy with preserved build tag annotation Behaviour
  • Successful deploy with overwritten build tag annotation - new annotation is 'Update changelog'

FYI, my aim is to use the annotation message to conditionally suppress the deploy as needed. While I imagine it would be possible to trap the original annotation on the original build (before the deploy update), if I wanted to re-build the tag, the expected behaviour would not be possible.

Thanks,

  1. Support Staff 1 Posted by Ilya Finkelshte... on 05 Jan, 2018 02:35 AM

    Ilya Finkelshteyn's Avatar

    Sorry I am struggling to understand what specific setting we need to preserve? Can you please point me where is in Get a release by tag name response?

  2. 2 Posted by Marshall Roch on 08 Jan, 2018 09:43 PM

    Marshall Roch's Avatar

    I think I'm having a similar problem.

    For facebook/flow, we push a tag, then use the GitHub API or web UI to create the release, writing a custom release description. Meanwhile, appveyor creates the windows build and uploads it to the existing release, but it also either overwrites the description with the commit message, or erases the existing description causing github to fall back to the commit message, because the `description` field in the `deploy` config isn't set. Not sure which is happening but the result is that the custom description is replaced by the commit message.

    We have `force_update` set to true, because at the time it was failing to upload the artifact to an existing release without it, but based on the OP it sounds like maybe that's no longer an issue. Trevor, are you using force_update?

  3. Support Staff 3 Posted by Ilya Finkelshte... on 09 Jan, 2018 07:07 PM

    Ilya Finkelshteyn's Avatar

    Hi Marshall and Trevor,

    Please watch this issue. Fix will be deployed in a week or so.

    However, as Marshall noted, if you need only artifact upload you can simple remove force_update: true (or uncheck Update release details if exists is you use UI). If you still need other release details to be updated, please watch issue mentioned above.

    Ilya.

  4. 4 Posted by trevor.sandy on 17 Jan, 2018 01:04 AM

    trevor.sandy's Avatar

    Hi - Sorry for my delay to respond. Yes, I am using force_update: true.
    I solved my specific issue by constructing an environment variable that is the same as the annotation and placing it at release: $(RELEASE_LABEL) under deploy.provider...

    However, it looks like the problem is the same as Marshall's and I would have the same behaviour if my annotation was dynamic. Cheers.

  5. Support Staff 5 Posted by Ilya Finkelshte... on 17 Jan, 2018 07:59 AM

    Ilya Finkelshteyn's Avatar

    I see. Proper fix is checked in, but current milestone appears to be pretty heavy and require additional testing, so we are targeting end of this week now.

  6. Support Staff 6 Posted by Ilya Finkelshte... on 24 Jan, 2018 09:28 PM

    Ilya Finkelshteyn's Avatar

    Should be fixed now.

  7. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:26 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac