Install latest ASP.Net 5 tools on Visual Studio 2015 image

jpapp's Avatar

jpapp

03 Sep, 2015 05:27 PM

With the release of ASP.NET 5 Beta7 there are breaking changes due to some renames.

Microsoft recommends installing the latest tooling to fix this: https://github.com/aspnet/Announcements/issues/44

Is it possible to get that tooling installed on the VS 2015 image?

  1. Support Staff 1 Posted by Feodor Fitsner on 03 Sep, 2015 09:04 PM

    Feodor Fitsner's Avatar

    Is that tooling update required if you run your builds from command line in AppVeyor?

  2. 2 Posted by jpapp on 03 Sep, 2015 10:57 PM

    jpapp's Avatar

    I tried to run the build from a command line manually and it still didn't work on the build worker.

    Looks like there is a bug in the version of the VS 2015 Community tooling that is installed on the build worker that causes this issue. This GitHub issues describes it and it sounds like the only solution is to install the newer tooling.

    https://github.com/aspnet/dnx/issues/2371#issuecomment-137141149

    I did RDP to the build worker on a failed build and verified that the ASP.NET and Web Tools version is 14.0.20711.0 which is the same one mentioned in that issue.

  3. Support Staff 3 Posted by Feodor Fitsner on 04 Sep, 2015 12:15 AM

    Feodor Fitsner's Avatar

    Do you have by chance a project in public repo reproducing this behavior?

    While being logged via RDP have you tried installing updated tooling (is it correct link?) to make sure it fixes the build.

  4. 4 Posted by jpapp on 04 Sep, 2015 03:02 PM

    jpapp's Avatar

    Here is a public repo showing this issue.

    https://github.com/squareitechnologies/AppveyorAspNet5Build

    You can see it builds fine with Beta6:

    https://ci.appveyor.com/project/Squarei/appveyoraspnet5build/build/1.0.1

    But just switching to Beta7 fails:

    https://ci.appveyor.com/project/Squarei/appveyoraspnet5build/build/1.0.4

    I did go onto the build worker and install the tooling in the init stage of the build and after that Beta7 worked fine:

    https://ci.appveyor.com/project/Squarei/appveyoraspnet5build/build/1.0.5

  5. Support Staff 5 Posted by Feodor Fitsner on 04 Sep, 2015 03:10 PM

    Feodor Fitsner's Avatar

    Perfect, thank you!

    Just to confirm, this should be installed, right? http://www.microsoft.com/en-us/download/details.aspx?id=48222

  6. 6 Posted by jpapp on 04 Sep, 2015 03:36 PM

    jpapp's Avatar

    I actually installed the Beta7 tools that came out on Wednesday which are located here:

    http://www.microsoft.com/en-us/download/details.aspx?id=48738

    I downloaded and ran the WebToolsExtensionsVS14.msi download on that page.

  7. Support Staff 7 Posted by Feodor Fitsner on 04 Sep, 2015 03:42 PM

    Feodor Fitsner's Avatar

    Oh, nice. Thanks for the link. I've added a new issue: https://github.com/appveyor/ci/issues/397

  8. 8 Posted by jpapp on 17 Sep, 2015 05:42 PM

    jpapp's Avatar

    This is working great. Thanks for making that change.

  9. jpapp closed this discussion on 17 Sep, 2015 05:42 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac