FTP deploy doesn't work when adding 'application' to deploy settings

ptf's Avatar

ptf

29 Sep, 2015 09:36 PM

I have successfully deployed a .zip file to the ftp server, but I can't unzip it.
This is my settings: (I've dotted out some information)

artifacts:
  - path: \
    name: myapp

deploy:
    # FTP deployment provider settings
  - provider: FTP
    protocol: ftp
    host: ...
    username: ...
    password:
      secure: ...
    folder: test
    application: myapp

When it tries to copy, it tells me this:
Uploading web application "myapp.zip" to FTP server "ftp://ftp...." as "test".
"test" is the folder, it should say "test/myapp.zip" as it did before I added "application" to the deploy settings.

Anyone know what is going on?

  1. Support Staff 1 Posted by Feodor Fitsner on 30 Sep, 2015 12:20 AM

    Feodor Fitsner's Avatar

    What is your goal here? application makes FTP provider unpacking zip artifact locally and then deploying it file-by-file to remote server.

  2. 2 Posted by ptf on 30 Sep, 2015 06:55 AM

    ptf's Avatar

    Ah, I misunderstood. I thought it somehow unpacked it on the remote ftp server. Nevermind then. The actual error message said the name of some file was too long, but I thought it was something wrong with the settings due to it saying it was uploading the artifacts as "test".

    I have somefolder with some deep folders which are not supposed to be there, removing them probably fixes it.

  3. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac