Bug? GitHub Release with appveyor_repo_tag on Ubuntu image failing. (SOLVED)

Ricky C's Avatar

Ricky C

04 May, 2018 06:44 PM

I've set up a dual-platform build system, both of which are to upload their artifacts to GitHub Releases when done. While the VS2017 image did so, the Ubuntu image seems confused.

Here's a link to the Ubuntu job: https://ci.appveyor.com/project/kf6kjg/anaximander2/build/job/w2r9w...
Here's a link to the matching VS2017 job: https://ci.appveyor.com/project/kf6kjg/anaximander2/build/job/apnw2...

As you can see at the top of the Ubuntu build, PowerShell saw that $env:APPVEYOR_REPO_TAG -eq "true" was true. At the bottom however you'll see "GitHub" deployment has been skipped as environment variable has not matched ("appveyor_repo_tag" is "", should be "true") Versus at the bottom of the VS2017 job you'll see it successfully deployed.

Did I trip across a bug or is there something wrong in my setup?

  1. Support Staff 1 Posted by Owen McDonnell on 04 May, 2018 07:10 PM

    Owen McDonnell's Avatar

    Perhaps you just need to capitalize 'appveyor_repo_tag' in deploy: section of yaml?

  2. 2 Posted by Ricky C on 04 May, 2018 07:33 PM

    Ricky C's Avatar

    I certainly could give that a try. Doesn't match docs though:
    https://www.appveyor.com/docs/deployment/github/#release-every-tag-build

  3. Support Staff 3 Posted by Owen McDonnell on 04 May, 2018 08:47 PM

    Owen McDonnell's Avatar

    I think that is whats going on. I created an issue for it here

  4. 4 Posted by Ricky C on 04 May, 2018 09:40 PM

    Ricky C's Avatar

    That worked. Definitely a case sensitivity issue.

    Successful Ubuntu job: https://ci.appveyor.com/project/kf6kjg/anaximander2/build/job/xc0m8...
    Matching successful VS2017 job: https://ci.appveyor.com/project/kf6kjg/anaximander2/build/job/9ait0...

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac