netstandard & netcoreapp

Nauzet's Avatar

Nauzet

07 May, 2018 05:05 PM

Hi I have been this weekend setting up my project with appveyor + sonarqube. It consist on a netstandard library and a netcoreapp unit tests project.I was trying to use the latest versions possible (2.1.0-rc1 released hours ago) and made it work locally but I was unable to do it on appveyor so I rolled it back to 2.0.7 but I am fine with it, is not required. Just wondering if someone was able to use more recent versions than mine.

This is my csproj for the netstandard: https://github.com/Ralstlin/ArqueBus/blob/master/src/ArqueBus/ArqueBus.csproj
This is for the unit tests in netcoreapp: https://github.com/Ralstlin/ArqueBus/blob/master/tests/ArqueBus.Tests/ArqueBus.Tests.csproj

https://ci.appveyor.com/project/Ralstlin/arquebus

  1. Support Staff 1 Posted by Owen McDonnell on 07 May, 2018 08:47 PM

    Owen McDonnell's Avatar

    Can you point me to a specific build that succeeded for you locally but failed on AppVeyor?

  2. 2 Posted by Nauzet on 08 May, 2018 10:18 PM

    Nauzet's Avatar

    Hi Owen!

    I made it work... partially! Seems everything is fine less OpenCover. Can you see: https://ci.appveyor.com/project/Ralstlin/arquebus/build/1.0.147 around line 160 it failed to run the tests but as I show in the attached screenshot it works locally.

    I think is because I installed: https://download.microsoft.com/download/B/1/9/B19A2F87-F00F-420C-B4... for the latest version. Do I need to add an install command for it?

  3. Support Staff 3 Posted by Owen McDonnell on 09 May, 2018 01:44 AM

    Owen McDonnell's Avatar

    It seems that you are still trying to run these tests in a dotnet core preview runtime but that you tried to update it with a chocolatey command (which is now commented out). The 2.1.0rc-1 release package was added to chocolatey just today. Have you tried uncommenting that line (i think choco upgrade dotnetcore --pre would perhaps be preferable)?

  4. 4 Posted by Nauzet on 09 May, 2018 06:41 PM

    Nauzet's Avatar

    Thanks Owen! Yes I tried before the dotnetcore --pre but id didnt work so I commented it out. Thanks for let me know they upgraded to the latest :D Now it works fine.

    My concern is that I expected this to work without installing .Net Core and just using latest VS preview: https://blogs.msdn.microsoft.com/visualstudio/2018/05/07/visual-stu...

  5. Support Staff 5 Posted by Owen McDonnell on 09 May, 2018 09:50 PM

    Owen McDonnell's Avatar

    Do you mean that you expect the latest VS preview to be pre-installed on the build image?

  6. 6 Posted by Nauzet on 10 May, 2018 08:36 PM

    Nauzet's Avatar

    as my image is Visual Studio Preview I thought it will come with the SDK but not sure how often appVeyor update the VS preview image and not even if it really comes with the SDK (I updated to the latest preview and anyway had to install the sdk manually)

  7. Support Staff 7 Posted by Owen McDonnell on 10 May, 2018 09:32 PM

    Owen McDonnell's Avatar

    Yes, you are correct but, alas, sometimes image updates don't happen perfectly on schedule (particularly when conferences get in the way). You can follow the main platform updates here. Once Visual studio is updated on the main vs2017 image, you can expect that the preview will then refer to the 15.8 preview.
    Also, you can see whats upcoming in the 'next-images-update' milestone.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac