Platform: x86 is not 32 bit?

tony's Avatar

tony

05 Mar, 2014 03:21 PM

Just wondering why in a test build where I set Platform: x86 in appveyor.yml (https://ci-beta.appveyor.com/project/tkelman/julia/build/1.0.153), the environment variable PROCESSOR_ARCHITECTURE is AMD64, and Chocolatey installs 64-bit versions of requested applications?

  1. Support Staff 1 Posted by Feodor Fitsner on 05 Mar, 2014 05:15 PM

    Feodor Fitsner's Avatar

    Yeah, Platform setting is related to MSBuild (VS solution/project configuration/platform), not OS bitness - it's still Windows Server 2012. I will add some notes to the docs to remove confusion.

    Are you interested in testing under 32-bit OS?

  2. 2 Posted by tony on 05 Mar, 2014 06:10 PM

    tony's Avatar

    I see, that makes perfect sense. So the platform setting is more like "host" in *nix-speak, rather than "build." 32-bit OS is not so common these days, but I work with numerical/scientific computing software that runs into bugs specific to 32-bit more often than other types of code. This may be a niche use area, and I should also be able to compile and run 32-bit code from 64-bit OS just fine.

    Though I see there is a section for "os:" in appveyor.yml, is there presumably only one valid choice for that right now?

  3. Support Staff 3 Posted by Feodor Fitsner on 05 Mar, 2014 09:49 PM

    Feodor Fitsner's Avatar

    Yeah, Windows Server 2012 is the only template right now. We plan to add Windows Server 2008 R2 and 2012 R2 soon after launch.

    If there is demand we could deploy Windows 8 32-bit too (I read somewhere that it's possible on Azure).

  4. 4 Posted by tony on 07 Mar, 2014 05:36 AM

    tony's Avatar

    An update: 32-bit builds compile and run properly as-is. They're failing tests at the moment, but in this case it's a known numerical precision issue and part of the reason we want CI.

  5. Support Staff 5 Posted by Feodor Fitsner on 07 Mar, 2014 06:05 AM

    Feodor Fitsner's Avatar

    Thanks for the update. I will start playing with Windows 8 images after 2.0 launch.

  6. 6 Posted by tony on 28 Mar, 2014 12:16 AM

    tony's Avatar

    Are the 64-bit Visual Studio command-line tools installed on the VMs? I tried running %VS120COMNTOOLS%\..\..\VC\bin\vcvars64.bat (or with VS110COMNTOOLS) but no luck.

  7. Support Staff 7 Posted by Feodor Fitsner on 28 Mar, 2014 12:32 AM

    Feodor Fitsner's Avatar

    I'm not sure - will take a look.

    - Feodor

  8. 8 Posted by tony on 28 Mar, 2014 12:35 AM

    tony's Avatar

    Alternately I tried "%VS120COMNTOOLS%\..\..\VC\vcvarsall.bat" amd64 and that resulted in

    The specified configuration type is missing.  The tools for the
    configuration might not be installed.
    
  9. Support Staff 9 Posted by Feodor Fitsner on 28 Mar, 2014 05:09 AM

    Feodor Fitsner's Avatar

    Apparently, VS Express comes with "x86_amd64" configuration only. I saw someone suggested to use "C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd" /x64

  10. 10 Posted by tony on 28 Mar, 2014 05:20 AM

    tony's Avatar

    Thanks for looking into it! Ok, I guess it only does 32-bit compiler executable generating 64-bit output. I think that should be fine for my purposes.

    "%VS120COMNTOOLS%\..\..\VC\vcvarsall.bat" x86_amd64 worked well, I should've tried that before posting.

  11. Support Staff 11 Posted by Feodor Fitsner on 28 Mar, 2014 05:29 AM

    Feodor Fitsner's Avatar

    Thanks for the update!

  12. 12 Posted by david.turner on 02 Apr, 2014 07:26 PM

    david.turner's Avatar

    Hi, do you have an ETA for Windows Server 2012 R2 or Windows 8.1 support?

    Thanks,

    Dave

  13. Support Staff 13 Posted by Feodor Fitsner on 02 Apr, 2014 07:30 PM

    Feodor Fitsner's Avatar

    Hi Dave,

    Technically, everything is ready for that - I'm going to start doing 2012 R2 image this week.

    Can I ask why do you need 2012 R2 or Windows 8.1?

  14. 14 Posted by David Foster on 20 Jul, 2015 03:52 AM

    David Foster's Avatar

    I was also confused by (platform: x86) not actually being 32-bit Windows.

    It does not appear that the documentation has been updated everywhere to make this clear. In particular the appveyor.yml reference does not make a distinction:
    * http://www.appveyor.com/docs/appveyor-yml

  15. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:58 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac