Is the default timezone different between Visual Studio 2017 and 2015's images?

BobbyA's Avatar

BobbyA

14 Sep, 2018 06:55 PM

I'm updating my repo's appveyor.yml file to use the Visual Studio 2017 image instead of the 2015 image. Is the default timezone different between the two? I have a few unit tests that assumes the local timezone is UTC. Was this an intended change?

  1. 1 Posted by BobbyA on 14 Sep, 2018 07:00 PM

    BobbyA's Avatar

    The Visual Studio 2017 image appears to be using the Mountain Time Zone. I started a build 6:50PM UTC and saw the following in the build console:

    Write-Host "**** Feature Build Init $(Get-Date)" -foregroundcolor white -backgroundcolor black
    **** Feature Build Init 09/14/2018 11:50:59

  2. 2 Posted by BobbyA on 14 Sep, 2018 07:18 PM

    BobbyA's Avatar

    Verifying that when I switched back to the Visual Studio 2015 image, times were reported in UTC. Can the Visual Studio 2017 image be updated to default to UTC?

  3. Support Staff 3 Posted by Feodor Fitsner on 15 Sep, 2018 12:35 AM

    Feodor Fitsner's Avatar

    We are going to fix that in the next image update: https://github.com/appveyor/ci/issues/2635

  4. Feodor Fitsner closed this discussion on 15 Sep, 2018 12:40 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac