FTP XCopy Deployment package unzipped to server

dirkvanbergen's Avatar


05 Mar, 2019 01:18 PM


I'm trying to get a very simple ASP.Net MVC (4.5) web application deployed via FTP to my hosting provider. Using another method of deploying other than FTP is not an option unfortunately. The Build action to package the web application for XCopy is perfect. I've copied that .zip file to the target folder on my FTP server with appveyor no problem. Then manually extracted all the files in the destination, and the site worked great. However, I'd like to skip the manual step and copy the files individually from the archive rather than the zip package. Is there a way to do that instead?



  1. 1 Posted by Owen McDonnell on 05 Mar, 2019 05:26 PM

    Owen McDonnell's Avatar

    Can you share your configuration as it is now. If you use UI you can go to settings -> export YAML.

  2. 2 Posted by Owen McDonnell on 05 Mar, 2019 05:27 PM

    Owen McDonnell's Avatar

    But a brief answer would be that if the artifacts section of ftp deploy settings is left blank, all declared artifacts will be uploaded.
    This is described here in the docs.

  3. 3 Posted by dirkvanbergen on 05 Mar, 2019 06:12 PM

    dirkvanbergen's Avatar

    Oh the problem is not that the artifact doesn't get uploaded, by problem is that the artifact is a .zip file and I want it extracted in the destination, not as a .zip.

  4. 4 Posted by Owen McDonnell on 05 Mar, 2019 11:47 PM

    Owen McDonnell's Avatar

    I see. In that case you can use the application field of the deployment settings. But you need a named artifact to pass to it. If you are using Package Web Applications for XCopy deployment AppVeyor automatically names the artifact after the .NET project name.

  5. 5 Posted by dirkvanbergen on 06 Mar, 2019 05:50 AM

    dirkvanbergen's Avatar

    Wow really that easy. Awesome. Thanks!

  6. Owen McDonnell closed this discussion on 06 Mar, 2019 04:59 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac