Nested Virtualization needed for OpenSource projects (VT-x is not available (VERR_VMX_NO_VMX))

jonashackt's Avatar

jonashackt

24 Feb, 2020 10:36 AM

Hi there, I'am thinking about helping out the Ansible Molecule team to create some CI test jobs for the project https://github.com/ansible-community/molecule-vagrant, which is part of the great Molecule project. I already created an example project to show the general possibilty to run Vagrant/VirtualBox on AppVeyor https://github.com/jonashackt/vagrant-ansible-on-appveyor, which I didn't got to work back in late 2018. Now I wanted to catch up again (after reading through some newer posts like https://help.appveyor.com/discussions/problems/22269-packer-build-f..., where the new Windows Server 2019 images are mentioned) and was hoping to finally get it runnin. But sadly, I ended up with the same error like back in 2018:

VT-x is not available (VERR_VMX_NO_VMX) (see this build log for details: https://ci.appveyor.com/project/quakefrog/vagrant-ansible-on-appvey...)

Is there a way to get a nested hypervisor enabled build machine for https://github.com/jonashackt/vagrant-ansible-on-appveyor and later for https://github.com/ansible-community/molecule-vagrant also? Would be really cool! I would also like to write some blog posts about that, since AppVeyor is the only free Cloud CI, where such thing could be possible :) (see https://stackoverflow.com/questions/31828555/using-vagrant-on-cloud...)

  1. 1 Posted by jonashackt on 24 Feb, 2020 10:47 AM

    jonashackt's Avatar

    I also tried to use the Windows Server 2019 image (see build https://ci.appveyor.com/project/quakefrog/vagrant-ansible-on-appvey...) but ended up with the error

    Build worker image not found: Windows Server 2019

    so I guessed, I need to send an email to the appveyor support for the activation of this image for my account. Maybe using the Windows Server 2019 has nested virtualization enabled (just guessing from https://help.appveyor.com/discussions/problems/22269-packer-build-f...)?!

    Oh, and since my account https://ci.appveyor.com/project/jonashackt/ is somehow blocked right now (see https://help.appveyor.com/discussions/problems/26379-no-builds-are-...), it would be great to have my account unblocked bevor. The account https://ci.appveyor.com/project/quakefrog was just created, since the other one didn't work anymore.

  2. Support Staff 2 Posted by Feodor Fitsner on 24 Feb, 2020 05:58 PM

    Feodor Fitsner's Avatar

    Hi Jonas,

    Thank you for using AppVeyor!

    Right now Visual Studio 2019 image is the one based on Windows Server 2019 OS with nested virtualization enabled. It has Hyper-V components installed as well. This image is available to all AppVeyor users without request.

    We've unlocked your account - it should be fine now. So, please give that image a try and let us know if there are any issues.

    And, of course, a blog post will be super helpful! :) Thank you for your support!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac