appveyor with conda

Wayne Nilsen's Avatar

Wayne Nilsen

11 Aug, 2017 01:04 PM

I cannot seem to install a conda package from a different channel. The package in question is here https://anaconda.org/bashtage/arch

My appveyor.yml file is below

build: false

environment:
  matrix:
    - PYTHON_VERSION: 3.4
      MINICONDA: C:\Miniconda3

init:
  - "ECHO %PYTHON_VERSION% %MINICONDA%"

install:
  - "set PATH=%MINICONDA%;%MINICONDA%\\Scripts;%PATH%"
  - conda config --set always_yes yes --set changeps1 no
  - conda update -q conda
  - conda info -a
  - conda config --add channels bashtage
  - conda install arch
  - "conda create -q -n test-environment python=%PYTHON_VERSION% numpy pandas scipy matplotlib arch"
  - activate test-environment
  - pip install ggplot

test_script:
  - python run_all_tests.py

thanks

  1. Support Staff 1 Posted by Ilya Finkelshte... on 11 Aug, 2017 08:38 PM

    Ilya Finkelshteyn's Avatar

    I was able to make it work with:

    • Any of 64-bit Miniconda. 32-bit did not work for me too.
    • -y switch in install statement. e.g. conda install arch -y (silently agree install new and upgrade existing packages)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac