Skip Directory for Appveyor agent deploy

mark.garcia's Avatar

mark.garcia

24 Nov, 2014 07:15 AM

I've seen web deploy skip directory option but there's no similar option for appveyor deployment.
Is there a way to have this option set in appveyor agent environment.

Thanks

  1. Support Staff 1 Posted by Feodor Fitsner on 24 Nov, 2014 02:33 PM

    Feodor Fitsner's Avatar

    Sure, we can easily add that. Will do that this week.

    -Feodor

  2. 2 Posted by mark.garcia on 25 Nov, 2014 02:47 AM

    mark.garcia's Avatar

    Thanks for the swift response.

  3. Support Staff 3 Posted by Feodor Fitsner on 27 Nov, 2014 04:46 AM

    Feodor Fitsner's Avatar

    It's been implemented. If you install the latest Deployment Agent there are two new parameters in provider settings: skip_files and skip_dirs: http://www.appveyor.com/docs/deployment/agent#deploying-website

    Let me know how that worked for you.

  4. 4 Posted by mark.garcia on 27 Nov, 2014 07:03 AM

    mark.garcia's Avatar

    You guys are the greatest. Thanks.

  5. 5 Posted by mark.garcia on 05 Feb, 2015 08:25 AM

    mark.garcia's Avatar

    I actually tried this now "skip_dirs" and I indicated "\\App_GlobalResources" and it still got replaced.

  6. 6 Posted by mark.garcia on 05 Feb, 2015 08:31 AM

    mark.garcia's Avatar

    Ohh, I haven't installed the latest deploy agent, let me try this.

  7. 7 Posted by mark.garcia on 05 Feb, 2015 08:54 AM

    mark.garcia's Avatar

    Deployment job started
    Found 1 deployable artifacts.
    Deploying Web application xxx.Web.xxx
    Downloading artifact package xxx.Web.xxx.zip (18,860,214 bytes)
    Method not found: 'Microsoft.Web.Administration.Site Microsoft.Web.Administration.SiteCollection.Add(System.String, System.String, System.String, Byte[], System.String)'.

    I got this error after deploying using the new agent.

  8. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:53 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

 

21 Mar, 2019 05:38 PM
21 Mar, 2019 06:16 AM
21 Mar, 2019 01:47 AM
20 Mar, 2019 11:39 PM
20 Mar, 2019 09:03 PM
20 Mar, 2019 08:55 PM