.NET Core RTM Support

bniemyjski's Avatar


07 Jun, 2016 04:03 PM

They just announced that .NET Core RTM will be released on the morning of the 27th. This is very important to get our rtm packages out there ASAP after it's released. Would it be possible to schedule a deployment of updated images on the 27th with Nuget 3.5 + .NET CLI Tooling (Preview 2) which will be released on the 27th (not sure about nuget but at least the latest 3.5 beta is out now).

Showing page 2 out of 2. View the first page

  1. Support Staff 31 Posted by Feodor Fitsner on 28 Jun, 2016 05:22 PM

    Feodor Fitsner's Avatar

    @michiel - could you please give me an exact command? I've tried dotnet --version and it worked fast.

    @jpapp - what are those packages and what command can be used to pre-populate the cache?

  2. 32 Posted by michiel on 28 Jun, 2016 05:27 PM

    michiel's Avatar

    You can do "dotnet new" and it will show the uncompressing of files.

  3. 33 Posted by jpapp on 28 Jun, 2016 05:28 PM

    jpapp's Avatar

    Looks like they fixed it from loading the local cache when calling dotnet --version https://github.com/dotnet/cli/issues/3580

    Calling dotnet restore on a project for the first time will trigger the local package cache. Maybe do dotnet new and then call dotnet restore in the same directory to make sure it does loads the local cache

  4. Support Staff 34 Posted by Feodor Fitsner on 28 Jun, 2016 05:34 PM

    Feodor Fitsner's Avatar

    OK, I see - will take a look. Thanks for fast responses.

  5. 35 Posted by bniemyjski on 28 Jun, 2016 06:42 PM

    bniemyjski's Avatar

    I'm also seeing this.. It's adding minutes to each build.

  6. Support Staff 36 Posted by Feodor Fitsner on 29 Jun, 2016 02:20 AM

    Feodor Fitsner's Avatar

    OK, deployed update with pre-cached dotnet tool.

  7. 37 Posted by bniemyjski on 14 Sep, 2016 12:10 AM

    bniemyjski's Avatar

    They just released version 1.0.1 (https://www.microsoft.com/net/core#windows) of .NET Core. It contains new sdk / runtime.

  8. Support Staff 38 Posted by Feodor Fitsner on 14 Sep, 2016 12:47 AM

    Feodor Fitsner's Avatar

    Perfect timing, thanks for the hint! Will deploy it this week.

  9. 39 Posted by chudinia on 19 Sep, 2016 02:02 PM

    chudinia's Avatar

    Hello, not clear if .Net Core 1.0.1 is supported.
    I'm getting the error: "The project is configured to use .NET Core SDK version 1.0.0-preview2-003131 which is not installed or cannot be found under the path C:\Program Files\dotnet...."

  10. Support Staff 40 Posted by Feodor Fitsner on 19 Sep, 2016 05:08 PM

    Feodor Fitsner's Avatar

    Image has been updated and .NET Core 1.0.1 is now available.

  11. 41 Posted by michiel on 19 Sep, 2016 08:39 PM

    michiel's Avatar

    Looks like it is installed, but the old dotnet is still on the PATH.

    When I execute dotnet --version, this is the result:
    dotnet --version

    this should be: 1.0.0-preview2-003131

  12. Support Staff 42 Posted by Feodor Fitsner on 20 Sep, 2016 05:10 PM

    Feodor Fitsner's Avatar

    Should be OK now. Give it another try please.

  13. 43 Posted by michiel on 20 Sep, 2016 06:23 PM

    michiel's Avatar

    Yes, everything ok now. Thanks!

  14. 44 Posted by bniemyjski on 20 Oct, 2016 05:36 PM

    bniemyjski's Avatar
  15. Support Staff 45 Posted by Feodor Fitsner on 20 Oct, 2016 05:38 PM

    Feodor Fitsner's Avatar

    From that page:

    We are releasing an update today which addresses an issue installing on a clean macOS Sierra system. The change is limited to the macOS installer. There are no changes in the runtime or tools; .NET Core 1.0.1 remains the latest release for Windows and Linux.

    Looks like we're good?

  16. 46 Posted by bniemyjski on 20 Oct, 2016 06:28 PM

    bniemyjski's Avatar

    Yeah I think so, just saw it and posted on here, looks like fixes are incoming for windows next month.

  17. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:09 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac