Steven Thuriot's Avatar

Steven Thuriot

27 Aug, 2013 06:00 PM

I regularly get a failed build when the actual source does compile. When looking at the build messages, the following stands out:

ERROR nuget.targets (90, 9): The process cannot access the file 'C:\Users\build-jc3syyavyu\AppData\Roaming\NuGet\NuGet.Config' because it is being used by another process.
ERROR nuget.targets (90, 9): The command ""d:\Builds\dnp81rrach\src\.nuget\nuget.exe" install "d:\Builds\dnp81rrach\src\MYPROJECT\packages.config" -source "" -RequireConsent -o "d:\Builds\dnp81rrach\src\packages"" exited with code 1.

This has happened several times now. I somewhat get the feeling if someone else is running a build that is using nuget package restore as well, the second build fails. When I queue the build again manually, it succeeds.

Just thought I'd let you know! It's not a major setback as I couldn't be happier with the service! I'm always surprised however when I get that mail that my build has failed.

  1. Support Staff 1 Posted by Feodor Fitsner on 28 Aug, 2013 12:57 AM

    Feodor Fitsner's Avatar

    Hi Steven,

    Thanks for heads up! I've also noticed that problem once and am going to investigate.
    We recently rebuild a build server image with all the latest software, maybe this could be a problem.

    Oh and I glad you like the service! :)


  2. Support Staff 2 Posted by Feodor Fitsner on 11 Sep, 2013 06:59 PM

    Feodor Fitsner's Avatar


    I've found that if you update NuGet.exe in ".nuget" folder to the latest 2.7.x version the problem goes away. Just remove entire .nuget folder and then do "Enable NuGet restore" from VS.NET again.

    Please let me know if it works for you.


  3. 3 Posted by Steven Thuriot on 11 Sep, 2013 07:14 PM

    Steven Thuriot's Avatar

    Thanks Feodor,

    Since I never commit the nuget.exe file, I've just tried to update the targets file. Seems a few things have changed there too!

    The error hasn't occurred for quite a while, so something else might have already fixed it. I'll keep you updated if it happens again.

    Kind regards,

  4. Support Staff 4 Posted by Feodor Fitsner on 11 Sep, 2013 07:16 PM

    Feodor Fitsner's Avatar

    Cool, thank you!

  5. 5 Posted by Steven Thuriot on 03 Oct, 2013 12:23 PM

    Steven Thuriot's Avatar

    Problem seems to be resolved. Feel free to close the issue! :)

  6. Support Staff 6 Posted by Feodor Fitsner on 03 Oct, 2013 04:29 PM

    Feodor Fitsner's Avatar

    Fantastic, thanks for the update!

  7. Feodor Fitsner closed this discussion on 03 Oct, 2013 04:29 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac


06 Jun, 2024 02:12 PM
06 Jun, 2024 03:49 AM
04 Jun, 2024 03:53 AM
30 May, 2024 04:03 PM
27 May, 2024 02:06 AM
20 May, 2024 09:52 PM