Output directories not in msbuild files?

Geert van Horrik's Avatar

Geert van Horrik

02 Dec, 2014 04:35 PM

Please look at this build log (at the end where it runs GitLink):


On all build servers, this works good except AppVeyor. I already implemented several workarounds in GitLink to support fallback values, etc. Basically it tries to get the output directory of a project:


It uses TargetDir (which should be available). After that it falls back to OutputPath and OutDir. None of these properties have an evaluated property value in AppVeyor. Do you have any idea how this is possible? If I run this on other systems (continua ci, teamcity, etc, it works fine). Maybe the agent uses a different installation setup of visual studio / msbuild?

If you want I can give you a command line tool that dumps all available properties to the console, but you can also easily clone GitLink and run it on any project on your local machine as well.

  1. Support Staff 1 Posted by Feodor Fitsner on 02 Dec, 2014 07:52 PM

    Feodor Fitsner's Avatar

    OK, I see MSBuild API is used to analyze the project. Yes, a simple command line tool localizing the issue would be great.

    Btw, I'm wondering where do you select current platform/configuration to read correct settings?

  2. 2 Posted by Geert van Horri... on 03 Dec, 2014 08:44 AM

    Geert van Horrik's Avatar

    I have created the command line tool here:


    Full source here:


    Note that you have to run it in the directory containing a solution file *or* set the working directory. It will create output.log in the same directory as the DumpMsbuildProperties.exe with all properties dumped.

    I hope it can help you find the issue.

  3. Support Staff 3 Posted by Feodor Fitsner on 03 Dec, 2014 05:54 PM

    Feodor Fitsner's Avatar
  4. 4 Posted by Geert van Horri... on 03 Dec, 2014 05:56 PM

    Geert van Horrik's Avatar

    Bizarre. Can you update the configuration by also building https://github.com/oxyplot/oxyplot?

  5. Support Staff 5 Posted by Feodor Fitsner on 03 Dec, 2014 06:03 PM

    Feodor Fitsner's Avatar

    But I did nothing - just ran your example on AV...

    How do you pass current configuration into GitLink? Maybe this is the problem?

  6. 6 Posted by Geert van Horri... on 03 Dec, 2014 06:04 PM

    Geert van Horrik's Avatar

    Defaults to release (just like this one does), I actually just copy/pasted the ProjectHelper. In GitLink you can specify -c debug to specify debug. The strange thing is that if I run it locally (just compile the sln => run gitlink), it all works.

  7. Support Staff 7 Posted by Feodor Fitsner on 03 Dec, 2014 06:05 PM

    Feodor Fitsner's Avatar

    This is "works on my machine" problem :)

  8. 8 Posted by Geert van Horri... on 03 Dec, 2014 06:06 PM

    Geert van Horrik's Avatar

    I use GitLink on a lot of projects, never had this issue before. So for me it's either OxyPlot or AppVeyor (but since it worked locally, I assumed AppVeyor).

  9. 9 Posted by Geert van Horri... on 08 Dec, 2014 12:30 PM

    Geert van Horrik's Avatar

    Added -debug to GitLink and reran the build. Looks like OutDir is empty. Going to investigate why:


  10. 10 Posted by Geert van Horri... on 08 Dec, 2014 02:01 PM

    Geert van Horrik's Avatar

    Found the issue. You need to explicitly set the platform to "AnyCPU" instead of the default "Any CPU" it defaults to.


  11. Support Staff 11 Posted by Feodor Fitsner on 08 Dec, 2014 02:41 PM

    Feodor Fitsner's Avatar

    That's great, thanks for the update!


  12. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:50 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac