Start New Build Error

Jean-Simon Collard's Avatar

Jean-Simon Collard

04 Feb, 2019 04:39 PM


When I click on "New Build" on any project in appveyor, I get the error message pasted below. It has always worked fine and it stopped working during the weekend while we didn't change anything.

Cannot read last commit information from GitHub repository sherweb/Smo365Api: HTTP GET to returned status code 404: Not Found Full response body: {"message":"Not Found","documentation_url":""}

Thank you in advance,
Jean-Simon Collard

  1. Support Staff 1 Posted by Ilya Finkelshte... on 04 Feb, 2019 05:07 PM

    Ilya Finkelshteyn's Avatar

    Please check GitHub Authorization under account Settings > Authorizations (<account_name>/authorizations). Revoke GitHub access and authorize GitHub again if needed.

  2. 2 Posted by Jean-Simon Coll... on 04 Feb, 2019 05:35 PM

    Jean-Simon Collard's Avatar


    Thank you for your quick reply. We've tried with two different accounts and it did not change anything. We still have the same problem.

    We are using "Authorize as OAuth App". I know we can also use "Authorize as GitHub App". Do you think it makes a difference?

  3. Support Staff 3 Posted by Ilya Finkelshte... on 04 Feb, 2019 05:47 PM

    Ilya Finkelshteyn's Avatar

    It should work OK with OAuth. Do you see the same problem with other projects under your AppVeyor account? Can you create another project connected to the sherweb/smo365 repository (side-by-side with existing one) and check if you see the same error, for experiment?

  4. 4 Posted by Jean-Simon Coll... on 04 Feb, 2019 05:54 PM

    Jean-Simon Collard's Avatar


    We just discovered that some permission was removed and Appveyor could not access our Github anymore.

    Granting the permission seems to have fixed the issue.

    Thank you for your help, you can close this ticket.

    Jean-Simon Collard

  5. Support Staff 5 Posted by Ilya Finkelshte... on 04 Feb, 2019 05:58 PM

    Ilya Finkelshteyn's Avatar

    Good, thanks for the update!

  6. Ilya Finkelshteyn closed this discussion on 04 Feb, 2019 05:58 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

21 Aug, 2019 11:06 PM
21 Aug, 2019 02:08 PM
21 Aug, 2019 01:37 PM
21 Aug, 2019 10:21 AM
21 Aug, 2019 09:10 AM


21 Aug, 2019 05:56 AM
21 Aug, 2019 03:08 AM
20 Aug, 2019 11:33 PM
20 Aug, 2019 08:07 PM
20 Aug, 2019 05:50 PM
20 Aug, 2019 12:35 PM