deploy.ps1 -> Script exited with code -1073741502

kristian's Avatar

kristian

20 Feb, 2019 07:47 AM

Hi,
This used to work, but now the agent throws an exception:
"Script exited with code -1073741502"

As soon as a deploy.ps1 file is found, the error is thrown and deployment fails.
It looks like an error when the agent executes the powershell on the target machine.

  1. Support Staff 1 Posted by Ilya Finkelshte... on 20 Feb, 2019 07:06 PM

    Ilya Finkelshteyn's Avatar

    To investigate, I would first replace it with some super-simple "hello world" script and ensure it is executed OK. Then added some tracing into the existing script to determine which step actually fails, for example print which step is going to be executed and environment variable values.

  2. 2 Posted by kristian on 20 Feb, 2019 07:17 PM

    kristian's Avatar

    Hi Ilya,

    I have replaced the file with a simple script with a single write-host
    statement...
    error still occurres.

    Even though I have set the agent logging to verbose I cannot identify the
    issue.
    I think this could be related to permissions... can I enable more verbose
    logging?

    ons. 20. feb. 2019 kl. 20.06 skrev Ilya Finkelshteyn <
    [email blocked]>:

  3. Support Staff 3 Posted by Ilya Finkelshte... on 20 Feb, 2019 09:51 PM

    Ilya Finkelshteyn's Avatar

    Just to clarify -- you change logging verbosity level at %ProgramFiles%\AppVeyor\DeploymentAgent\Appveyor.DeploymentAgent.Service.exe.config? And looking to events at `Applications and Services Logs > AppVeyor'?

    Also what account AppVeyor Deployment agent service log on with (you can check in with a "Services" mmc snap-in)?

  4. 4 Posted by kristian on 21 Feb, 2019 07:45 AM

    kristian's Avatar

    Hi Ilya,

    Yes - thats where im looking for logs. The only events logged are:

        <Data>Deployment job finished: pybxy01hqpguj35b</Data>
        <Data>Deployment job pybxy01hqpguj35b error: Script exited with code
    -1073741502</Data>
        <Data>Looking for deploy.ps1 at C:\Struct\PIMSource\update
    deploy\PIM.Website\deploy.ps1</Data>

    The account is running as "Local System".
    However - im experiencing issues when trying to uninstall the agent.

    Apart from that, when trying to update the agent the following issue
    occurs:
    [image: 2019-02-21 08_43_36-pimpartner.com - Remote Desktop Connection
    Manager v2.7.png]

    Med venlig hilsen,

    Kristian Andersen
    Tlf: +45 2927 3937 | Mail: [email blocked]

    Struct A/S
    www.struct.dk

    Den ons. 20. feb. 2019 kl. 22.51 skrev Ilya Finkelshteyn <
    [email blocked]>:

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • 2019-02-20_08_47_24-struct.pimtemplate_-_AppVeyor_–_Google_Chrome.png 4.52 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac