Change in Git behaviour

philippe.elsass's Avatar


16 Oct, 2013 08:52 AM

We have some scripts peeking into .git/ to look for the current revision - it worked yesterday, but today it doesn't.
Did you change something?

Our script:

  1. Support Staff 1 Posted by Feodor Fitsner on 16 Oct, 2013 04:59 PM

    Feodor Fitsner's Avatar

    An updated Build Agent was deployed yesterday, but nothing breaking - just a fix for calling batch deployment script.

    What's wrong with Git though?

  2. 2 Posted by philippe.elsass on 16 Oct, 2013 05:14 PM

    philippe.elsass's Avatar

    We are reading files inside .git/ to determine the branch and commit number
    and it worked until yesterday.
    I'll try to figure what changed...

  3. Support Staff 3 Posted by Feodor Fitsner on 16 Oct, 2013 05:17 PM

    Feodor Fitsner's Avatar

    Yeah, that strange. A regular git executable is used on build servers to fetch sources and it wasn't updated...

    Hey, right now %commitid% could be found in environment variables when calling build script. I could add branch too.

  4. 4 Posted by philippe.elsass on 16 Oct, 2013 05:22 PM

    philippe.elsass's Avatar

    Were not using git for peeking into .git, but env variables are fine!

    Thanks and sorry for the troubles.

  5. Support Staff 5 Posted by Feodor Fitsner on 16 Oct, 2013 05:23 PM

    Feodor Fitsner's Avatar

    Cool, I will add a new TODO item for branch env var.

  6. Feodor Fitsner closed this discussion on 16 Oct, 2013 05:23 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac