Problem with std::thread

xwilarg's Avatar

xwilarg

20 Mar, 2019 01:15 PM

Hi,
I'm trying to setup appveyor for a C++ project
My .appveyor.yml looks like that: https://github.com/Xwilarg/ProgramManager/blob/master/.appveyor.yml
But appveyor is trying to build, it say the following error: 'thread' is not a member of 'std'
https://ci.appveyor.com/project/Xwilarg/programmanager

I don't think the error is from my code because it's working locally and also on Travis CI: https://travis-ci.org/Xwilarg/ProgramManager

Does someone know how I could fix that ?

Thanks in advance,

  1. Support Staff 1 Posted by Owen McDonnell on 20 Mar, 2019 06:03 PM

    Owen McDonnell's Avatar

    By locally you mean on windows or linux?

  2. 2 Posted by xwilarg on 20 Mar, 2019 08:48 PM

    xwilarg's Avatar

    By locally I mean Windows with MinGW 64 bit.

  3. Support Staff 3 Posted by Owen McDonnell on 01 Apr, 2019 05:51 AM

    Owen McDonnell's Avatar

    Sorry for late response.
    I'm not sure where you are with this problem and i don't have a vast knowledge of MinGW, but if I understand this post correctly, the version of MingW you're using might not support threads?
    Do you use the same version locally?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac